mplayer: add dependency libraries to a variable
authorHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 1 Dec 2008 12:48:58 +0000 (12:48 -0000)
committerHans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
Mon, 1 Dec 2008 12:48:58 +0000 (12:48 -0000)
This patch will put dependency libraries in a variable and add this to the
dependencies to build mplayer. This is done to ease adding new libraries in the
future.

Signed-off-by: Hans-Christian Egtvedt <hans-christian.egtvedt@atmel.com>
package/multimedia/mplayer/mplayer.mk

index 446d38d4b391c2370cfb5ec9af243966b73391ee..47f2a86f714677e67f699198fc9af1a2b6a6ed5c 100644 (file)
@@ -17,6 +17,8 @@ else
 MPLAYER_ENDIAN:=--disable-big-endian
 endif
 
+MPLAYER_DEP_LIBS:=libmad
+
 $(DL_DIR)/$(MPLAYER_SOURCE):
        $(WGET) -P $(DL_DIR) $(MPLAYER_SITE)/$(MPLAYER_SOURCE)
 
@@ -60,7 +62,7 @@ $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY): $(MPLAYER_DIR)/$(MPLAYER_BINARY)
        -$(STRIPCMD) $(STRIP_STRIP_UNNEEDED) $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
        touch -c $@
 
-mplayer: uclibc libmad $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
+mplayer: uclibc $(MPLAYER_DEP_LIBS) $(TARGET_DIR)/$(MPLAYER_TARGET_BINARY)
 
 mplayer-source: $(DL_DIR)/$(MPLAYER_SOURCE)