vlc: enable altivec support only when appropriate
authorSamuel Martin <s.martin49@gmail.com>
Sat, 8 Feb 2014 14:34:55 +0000 (15:34 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 8 Feb 2014 21:09:42 +0000 (22:09 +0100)
All PowerPC CPUs do not support altivec instruction set; so enable its
support only when the sub-architecture support it.

Signed-off-by: Samuel Martin <s.martin49@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/vlc/vlc.mk

index b184de34e4fc84912c5bfa5fc744c39356c1e969..2730f07980e2cb204e18dd74baf6e7b5bc6f47ea 100644 (file)
@@ -32,6 +32,13 @@ VLC_CONF_OPT += \
        --disable-vsxu \
        --disable-mtp
 
+# Set powerpc altivec appropriately
+ifeq ($(BR2_powerpc_7400)$(BR2_powerpc_7450)$(BR2_powerpc_970),y)
+VCL_CONF_OPT += --enable-altivec
+else
+VLC_CONF_OPT += --disable-altivec
+endif
+
 ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
 VLC_CONF_OPT += --enable-alsa
 VLC_DEPENDENCIES += alsa-lib