gdb: force to use ncurses and not termcap for host-gdb
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 29 Jul 2017 20:06:26 +0000 (22:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 1 Aug 2017 21:37:06 +0000 (23:37 +0200)
Both our target and host gdb depend on ncurses (host-ncurses for
host-gdb, of course). However, while for the target we passs
--with-curses, we are not doing this for the host variant. Due to
this, host-gdb default to using the termcap library: if such a library
is available on the build system, it will be used instead of the
host-ncurses we have built. This causes the host gdb binary to depend
on a library that we do not provide in $(HOST_DIR), breaking the
principle of a standalone SDK (which should only depend on the C
library).

To solve this, we simply pass --with-curses in HOST_GDB_CONF_OPTS,
which forces host-gdb to use the host-ncurses library.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gdb/gdb.mk

index 73b0ea09d97d5df7106c851b277a48f44385b2f5..1fef0d4f5e888c498b36086bdfa3f1877f980bde 100644 (file)
@@ -203,6 +203,7 @@ HOST_GDB_CONF_OPTS = \
        --enable-threads \
        --disable-werror \
        --without-included-gettext \
+       --with-curses \
        $(GDB_DISABLE_BINUTILS_CONF_OPTS)
 
 ifeq ($(BR2_PACKAGE_HOST_GDB_TUI),y)