package/lttng-{libust, tools}: use proper systemd rundir
authorNorbert Lange <nolange79@gmail.com>
Fri, 26 Jun 2020 22:06:02 +0000 (00:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 27 Jun 2020 14:44:35 +0000 (16:44 +0200)
Set the rundir to /run/lttng, if systemd is the init system.
/var/run is "legacy" in systemd's view.

Signed-off-by: Norbert Lange <nolange79@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/lttng-libust/lttng-libust.mk
package/lttng-tools/lttng-tools.mk

index 8e6537690bd27e577dfea22b84c663d047aba4b1..f3c660c56f7266a2345e3e18f501eb071b2e5f87 100644 (file)
@@ -13,6 +13,10 @@ LTTNG_LIBUST_INSTALL_STAGING = YES
 LTTNG_LIBUST_DEPENDENCIES = liburcu util-linux
 LTTNG_LIBUST_CONF_OPTS += --disable-man-pages --disable-examples
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+LTTNG_LIBUST_CONF_OPTS += --with-lttng-system-rundir=/run/lttng
+endif
+
 ifeq ($(BR2_PACKAGE_PYTHON),y)
 LTTNG_LIBUST_DEPENDENCIES += python
 LTTNG_LIBUST_CONF_OPTS += --enable-python-agent
index b1b0a24a4f03b2870a16e05bee1a550dea545bdf..e0e99e327013e4e87c38eed4cf06cce9cb78de94 100644 (file)
@@ -13,6 +13,10 @@ LTTNG_TOOLS_LICENSE_FILES = LICENSE $(addprefix LICENSES/,BSD-2-Clause BSD-3-Cla
 LTTNG_TOOLS_CONF_OPTS += --disable-man-pages
 LTTNG_TOOLS_DEPENDENCIES = liburcu libxml2 popt util-linux
 
+ifeq ($(BR2_INIT_SYSTEMD),y)
+LTTNG_TOOLS_CONF_OPTS += --with-lttng-system-rundir=/run/lttng
+endif
+
 ifeq ($(BR2_PACKAGE_LTTNG_LIBUST),y)
 LTTNG_TOOLS_CONF_OPTS += --with-lttng-ust
 LTTNG_TOOLS_DEPENDENCIES += lttng-libust