package/berkeleydb: fix shared-only build
authorYann E. MORIN <yann.morin.1998@free.fr>
Fri, 12 Dec 2014 18:18:51 +0000 (19:18 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 13 Dec 2014 09:36:02 +0000 (10:36 +0100)
Changeset f1d3e09 (Build shared libraries only as the default) broke the
berkeleydb package.

For some reason, we had a very strange post-configure action in bdb:
        $(SED) 's/\.lo/.o/g' $(@D)/build_unix/Makefile

This means that it is using non-libtool object files. This breaks
building shared-only.

This code has been present almost the whole time we've had a berkeleydb
package, that is:
  - November 2003: use a sed expression instead of perl
  - March 2003   : use a perl program
  - August 2002  : introduce berkeleydb

Getting rid of this sed expression fixes the build, and allows building
the three new static/shared combinations: static only, shared only,
both static and shared.

Fixes numerous build failures:
    http://autobuild.buildroot.net/results/b41/b41e13ec6c13830667770b3731f8990062f202bd/
    http://autobuild.buildroot.net/results/925/925433ef505b190aa5ac83c23e9359afe4b21829/
    http://autobuild.buildroot.net/results/9af/9afa0dd835af079411a2ea5d94e5e4db7c993111/
    ...

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/berkeleydb/berkeleydb.mk

index 452c787f2363dff5d5132f41fb9f95457bca33ee..30fc5182ec09099295212a9a2793542c026fdfc6 100644 (file)
@@ -41,7 +41,6 @@ define BERKELEYDB_CONFIGURE_CMDS
                --with-pic \
                --enable-o_direct \
        )
-       $(SED) 's/\.lo/.o/g' $(@D)/build_unix/Makefile
 endef
 
 ifneq ($(BR2_PACKAGE_BERKELEYDB_TOOLS),y)