python-requests: bump to version 2.18.1
authorYegor Yefremov <yegorslists@googlemail.com>
Fri, 21 Jul 2017 08:12:30 +0000 (10:12 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 21 Jul 2017 21:04:52 +0000 (23:04 +0200)
Add new runtime dependencies and select Python SSL support.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/python-requests/Config.in
package/python-requests/python-requests.hash
package/python-requests/python-requests.mk

index 23ab3092d51c8952dbbc879bf07ac20473ef2c8c..d2726fb26a1a600dc41b2801645994a249b2dbd3 100644 (file)
@@ -1,5 +1,11 @@
 config BR2_PACKAGE_PYTHON_REQUESTS
        bool "python-requests"
+       select BR2_PACKAGE_PYTHON_CERTIFI # runtime
+       select BR2_PACKAGE_PYTHON_CHARDET # runtime
+       select BR2_PACKAGE_PYTHON_IDNA # runtime
+       select BR2_PACKAGE_PYTHON_URLLIB3 # runtime
+       select BR2_PACKAGE_PYTHON_SSL if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON3_SSL if BR2_PACKAGE_PYTHON3 # runtime
        select BR2_PACKAGE_PYTHON_ZLIB if BR2_PACKAGE_PYTHON # runtime
        select BR2_PACKAGE_PYTHON3_ZLIB if BR2_PACKAGE_PYTHON3 # runtime
        help
index 8faa9d0e8937dff4506ecf27dafbdb395c2e1fd2..2f182ea3bda4277116d8da40e3e9d82bcca14951 100644 (file)
@@ -1,3 +1,3 @@
 # md5 from https://pypi.python.org/pypi/requests/json, sha256 locally computed
-md5 921ec6b48f2ddafc8bb6160957baf444 requests-2.13.0.tar.gz
-sha256 5722cd09762faa01276230270ff16af7acf7c5c45d623868d9ba116f15791ce8 requests-2.13.0.tar.gz
+md5    40f723ed01dddeaf990d0609d073f021  requests-2.18.1.tar.gz
+sha256 c6f3bdf4a4323ac7b45d01e04a6f6c20e32a052cd04de81e05103abc049ad9b9  requests-2.18.1.tar.gz
index 13bbdfb5a22ba61c682311d39b80fd1fe93e7c6a..504eb8d0ad3fad0a1b895d7b0181877d69e33692 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-PYTHON_REQUESTS_VERSION = 2.13.0
+PYTHON_REQUESTS_VERSION = 2.18.1
 PYTHON_REQUESTS_SOURCE = requests-$(PYTHON_REQUESTS_VERSION).tar.gz
-PYTHON_REQUESTS_SITE = https://pypi.python.org/packages/16/09/37b69de7c924d318e51ece1c4ceb679bf93be9d05973bb30c35babd596e2
+PYTHON_REQUESTS_SITE = https://pypi.python.org/packages/2c/b5/2b6e8ef8dd18203b6399e9f28c7d54f6de7b7549853fe36d575bd31e29a7
 PYTHON_REQUESTS_SETUP_TYPE = setuptools
 PYTHON_REQUESTS_LICENSE = Apache-2.0
 PYTHON_REQUESTS_LICENSE_FILES = LICENSE