package/libkcapi: support building kcapi-enc application
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Tue, 20 Aug 2019 08:27:32 +0000 (10:27 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 27 Oct 2019 13:17:32 +0000 (14:17 +0100)
Just add a new Kconfig option in order to support building kcapi-enc
application.

Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libkcapi/Config.in
package/libkcapi/libkcapi.mk

index 1dbcdc381bc4da6ba7f7a95765a91400808d009b..8243f6b738eef455e2cbf7670cdb387232b58586 100644 (file)
@@ -8,6 +8,9 @@ config BR2_PACKAGE_LIBKCAPI
 
 if BR2_PACKAGE_LIBKCAPI
 
+config BR2_PACKAGE_LIBKCAPI_ENCAPP
+       bool "build enc application"
+
 config BR2_PACKAGE_LIBKCAPI_HASHER
        bool "build hasher application"
        depends on !BR2_STATIC_LIBS # dlfcn.h
index 48d34ffc40a2c57e311c8bbe416ad1fe11e20d50..dceacc001624e12c47385c34af9f3a48062b7e24 100644 (file)
@@ -16,6 +16,12 @@ LIBKCAPI_CONF_ENV = \
        ac_cv_path_DB2PS="" \
        ac_cv_path_XMLTO=""
 
+ifeq ($(BR2_PACKAGE_LIBKCAPI_ENCAPP),y)
+LIBKCAPI_CONF_OPTS += --enable-kcapi-encapp
+else
+LIBKCAPI_CONF_OPTS += --disable-kcapi-encapp
+endif
+
 ifeq ($(BR2_PACKAGE_LIBKCAPI_HASHER),y)
 LIBKCAPI_CONF_OPTS += --enable-kcapi-hasher
 else