grub: force -m32 so we build grub 32 bits on 64 bits architecture
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 4 Dec 2013 19:33:50 +0000 (20:33 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 4 Dec 2013 21:04:23 +0000 (22:04 +0100)
As reported by Matthew Weber, Grub doesn't build on 64 bits build
machines, because the host compiler produces 64 bits binaries by
default, while Grub should be built 32 bits. Therefore, this commit
passes -m32 to the Grub CFLAGS, so that 32 bits binaries are always
produced.

Reported-by: Matthew Weber <mlweber1@rockwellcollins.com>
Cc: Matthew Weber <mlweber1@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tested-by: Matthew Weber <mlweber1@rockwellcollins.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
boot/grub/grub.mk

index 6ba02cd5033aa8f2c5bd54720021bfd5c8bd1d0a..eb066af76cf416494fc6f77823d5484b3ba62156 100644 (file)
@@ -70,7 +70,7 @@ GRUB_POST_PATCH_HOOKS += GRUB_DEBIAN_PATCHES
 
 GRUB_CONF_ENV = \
        $(HOST_CONFIGURE_OPTS) \
-       CFLAGS="$(HOST_CFLAGS) $(GRUB_CFLAGS)"
+       CFLAGS="$(HOST_CFLAGS) $(GRUB_CFLAGS) -m32"
 
 GRUB_CONF_OPT = \
        --disable-auto-linux-mem-opt \