rauc: add missing dependencies for host variant
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Jul 2017 21:16:42 +0000 (23:16 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 2 Jul 2017 21:16:42 +0000 (23:16 +0200)
rauc unconditionally needs OpenSSL and libglib2. Those dependencies
were properly accounted for the target variant, but not the host
variant, causing build failures. This commit adds the missing
dependencies.

Fixes:

  http://autobuild.buildroot.net/results/2695202ee3b0734430abc2db03828a45cd5e5ef5
  (host-openssl missing)

  http://autobuild.buildroot.net/results/77a5db1120bf90ccaac00cfc0a8db358cacd894c
  (host-libglib2 missing)

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rauc/rauc.mk

index 12819d9251b31394302669cdbb50a63c51a934af..479a583206bf53b518919086b07e2363fa2557ca 100644 (file)
@@ -29,7 +29,7 @@ ifeq ($(BR2_PACKAGE_SYSTEMD),y)
 RAUC_DEPENDENCIES += systemd
 endif
 
-HOST_RAUC_DEPENDENCIES = host-pkgconf
+HOST_RAUC_DEPENDENCIES = host-pkgconf host-openssl host-libglib2
 HOST_RAUC_CONF_OPTS += --disable-network --disable-json --disable-service
 
 $(eval $(autotools-package))