openntpd: add optional dependency on LibreSSL
authorAdam Duskett <aduskett@gmail.com>
Wed, 8 Nov 2017 13:04:59 +0000 (08:04 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 22 Nov 2017 21:57:07 +0000 (22:57 +0100)
OpenNTPD looks for a crypto library with tls_config_set_ca_mem, which
is available in LibreSSL but not OpenSSL. If tls_config_set_ca_mem is
found, crypto support is added to the build.

Because this is not currently checked, crypto support might not be
added due to the order of the build. Add a small check to see if
BR2_PACKAGE_LIBRESSL is selected, and if so, add a dependency for it.

Also add a note about this in the Config.in help section.

Signed-off-by: Adam Duskett <aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openntpd/Config.in
package/openntpd/openntpd.mk

index 1b856c03b8f932c8c0b7b4ebbca63142744f2419..c84d0ba25bedee72782f9beb9d6a9ad9e441ffd0 100644 (file)
@@ -9,6 +9,9 @@ config BR2_PACKAGE_OPENNTPD
          to remote NTP servers and can act as NTP server itself,
          redistributing the local clock. It just works.
 
+         Crypto support is available if the LibreSSL library is
+         enabled.
+
          http://www.openntpd.org/
 
 comment "openntpd needs a toolchain w/ NPTL"
index 96d3881d21b143296ba1293704e9152d6f2c7529..f5a5690479593872a62a7380cc1cf5e79175b7e2 100644 (file)
@@ -11,6 +11,12 @@ OPENNTPD_LICENSE_FILES = COPYING
 # Need to autoreconf for our libtool patch to apply properly
 OPENNTPD_AUTORECONF = YES
 
+# Openntpd searches for tls_config_set_ca_mem which is only available
+# in LibreSSL
+ifeq ($(BR2_PACKAGE_LIBRESSL),y)
+OPENNTPD_DEPENDENCIES += openssl
+endif
+
 # openntpd uses pthread functions for arc4random emulation but forgets
 # to use -pthread
 OPENNTPD_CONF_ENV += CFLAGS="$(TARGET_CFLAGS) -pthread"