package/terminology: convert to the meson-package infrastructure
authorThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 28 Dec 2018 15:07:47 +0000 (16:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 30 Dec 2018 15:57:19 +0000 (16:57 +0100)
This conversion reduces the complexity of the .mk file, but also
allows to prepare terminology for per-package meson
cross-compilation.conf, where the cross-compilation.conf file will not
be located in $(HOST_DIR)/etc/meson/cross-compilation.conf.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/terminology/terminology.mk

index af37187d90ed47414cfcd5af89539cde5ec86891..3d144f86552b93cfad7a9e1bff99868de7f9382e 100644 (file)
@@ -10,31 +10,13 @@ TERMINOLOGY_SITE = https://download.enlightenment.org/rel/apps/terminology
 TERMINOLOGY_LICENSE = BSD-2-Clause
 TERMINOLOGY_LICENSE_FILES = COPYING
 
-TERMINOLOGY_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) efl host-meson host-pkgconf
-TERMINOLOGY_MESON_OPTS = \
-       --prefix=/usr \
-       --buildtype=$(if $(BR2_ENABLE_DEBUG),debug,release) \
-       --cross-file=$(HOST_DIR)/etc/meson/cross-compilation.conf \
-       -Dedje-cc=$(HOST_DIR)/bin/edje_cc
+TERMINOLOGY_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES) efl host-pkgconf
+TERMINOLOGY_CONF_OPTS = -Dedje-cc=$(HOST_DIR)/bin/edje_cc
 
 ifeq ($(BR2_SYSTEM_ENABLE_NLS),y)
-TERMINOLOGY_MESON_OPTS += -Dnls=true
+TERMINOLOGY_CONF_OPTS += -Dnls=true
 else
-TERMINOLOGY_MESON_OPTS += -Dnls=false
+TERMINOLOGY_CONF_OPTS += -Dnls=false
 endif
 
-define TERMINOLOGY_CONFIGURE_CMDS
-       rm -rf $(@D)/build
-       mkdir -p $(@D)/build
-       $(TARGET_MAKE_ENV) meson $(TERMINOLOGY_MESON_OPTS) $(@D) $(@D)/build
-endef
-
-define TERMINOLOGY_BUILD_CMDS
-       $(TARGET_MAKE_ENV) ninja -C $(@D)/build
-endef
-
-define TERMINOLOGY_INSTALL_TARGET_CMDS
-       $(TARGET_MAKE_ENV) DESTDIR=$(TARGET_DIR) ninja -C $(@D)/build install
-endef
-
-$(eval $(generic-package))
+$(eval $(meson-package))