package/autofs: fix mount, umount and fsck program paths
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 16 Aug 2019 09:09:13 +0000 (11:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 17 Aug 2019 12:46:17 +0000 (14:46 +0200)
Fixes:
 - https://bugs.buildroot.org/show_bug.cgi?id=11876

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/autofs/autofs.mk

index e7c65ef4b09cb5494549315e70c8f7cb89cc942c..0af00fa93655a9918bd074e1724e623adef67dac 100644 (file)
@@ -11,11 +11,18 @@ AUTOFS_LICENSE = GPL-2.0+
 AUTOFS_LICENSE_FILES = COPYING COPYRIGHT
 AUTOFS_DEPENDENCIES = host-flex host-bison host-pkgconf host-nfs-utils
 
-# autofs looks on the build machine for the path of modprobe, so tell
-# it explicitly where it will be located on the target.
+# autofs looks on the build machine for the path of modprobe, mount,
+# umount and fsck programs so tell it explicitly where they will be
+# located on the target.
 AUTOFS_CONF_ENV = \
+       ac_cv_path_E2FSCK=/usr/sbin/fsck.ext2 \
+       ac_cv_path_E3FSCK=/usr/sbin/fsck.ext3 \
+       ac_cv_path_E4FSCK=/usr/sbin/fsck.ext4 \
        ac_cv_path_KRB5_CONFIG=no \
        ac_cv_path_MODPROBE=/sbin/modprobe \
+       ac_cv_path_MOUNT=/bin/mount \
+       ac_cv_path_MOUNT_NFS=/usr/sbin/mount.nfs \
+       ac_cv_path_UMOUNT=/bin/umount \
        ac_cv_linux_procfs=yes
 
 # instead of looking in the PATH like any reasonable package, autofs