package/rng-tools: add nistbeacon option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 4 Apr 2020 21:36:53 +0000 (23:36 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 7 Apr 2020 07:17:25 +0000 (09:17 +0200)
Add an option to enable nistbeacon which is available since version 6.1
and
https://github.com/nhorman/rng-tools/commit/aefe862e187a1ef608f9826b2b4a5bbabd5e9945

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/rng-tools/Config.in
package/rng-tools/rng-tools.mk

index a86fbb0f74e6d8519f42a2fb086cb5cd6f395ef9..25b41f40d6d38264117e3ebdb863adb408d34232 100644 (file)
@@ -11,5 +11,22 @@ config BR2_PACKAGE_RNG_TOOLS
 
          http://sourceforge.net/projects/gkernel/
 
+if BR2_PACKAGE_RNG_TOOLS
+
+config BR2_PACKAGE_RNG_TOOLS_NISTBEACON
+       bool "NIST Entropy Beacon support"
+       select BR2_PACKAGE_JANSSON
+       select BR2_PACKAGE_LIBCURL
+       select BR2_PACKAGE_LIBXML2
+       help
+         Enable NIST Entropy Beacon support.
+
+         Entropy gathered from the NIST network entropy beacon. Note
+         that this entropy source is disabled by default as it should
+         never be used for cryptographic purposes, or any use case in
+         which random data should be known only by a single entity.
+
+endif
+
 comment "rng-tools needs a toolchain w/ NPTL"
        depends on !BR2_TOOLCHAIN_HAS_THREADS_NPTL
index 8ebfc0975ab890ea35962128429fa1b2a13567db..3baddb98ee88e6b538d0bf50cc2378a40b8eb404 100644 (file)
@@ -12,9 +12,7 @@ RNG_TOOLS_DEPENDENCIES = libsysfs jitterentropy-library host-pkgconf openssl
 # From git
 RNG_TOOLS_AUTORECONF = YES
 
-RNG_TOOLS_CONF_OPTS = \
-       --without-nistbeacon \
-       --without-pkcs11
+RNG_TOOLS_CONF_OPTS = --without-pkcs11
 
 # Work around for uClibc or musl toolchains which lack argp_*()
 # functions.
@@ -30,6 +28,13 @@ else
 RNG_TOOLS_CONF_OPTS += --without-rtlsdr
 endif
 
+ifeq ($(BR2_PACKAGE_RNG_TOOLS_NISTBEACON),y)
+RNG_TOOLS_DEPENDENCIES += jansson libcurl libxml2
+RNG_TOOLS_CONF_OPTS += --with-nistbeacon
+else
+RNG_TOOLS_CONF_OPTS += --without-nistbeacon
+endif
+
 define RNG_TOOLS_INSTALL_INIT_SYSV
        $(INSTALL) -D -m 755 package/rng-tools/S21rngd \
                $(TARGET_DIR)/etc/init.d/S21rngd