midori: force host-python dependency for waf build-system
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 26 May 2014 13:06:20 +0000 (15:06 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 26 May 2014 13:08:10 +0000 (15:08 +0200)
Fixes http://autobuild.buildroot.net/results/d48/d48b68dd6a43fa9a224237e8f458ca8987a3d7b4/

Similar to the recent fix to jack2 (fc8fcec306da). The waf version included
in midori (1.5.19) is not compatible with python 3.4.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/midori/midori.mk

index ff56e4386a1a2b68e807f0fdc2e717f07d4a0ed5..d55f5f1e2e5f9768e374cb4281c3e086752d7c31 100644 (file)
@@ -14,6 +14,7 @@ MIDORI_DEPENDENCIES = \
        host-intltool \
        host-pkgconf \
        host-vala \
+       host-python \
        libgtk2 \
        libsexy \
        webkit \
@@ -30,18 +31,18 @@ define MIDORI_CONFIGURE_CMDS
        $(MIDORI_WITHOUT_X11)
        (cd $(@D); \
                $(TARGET_CONFIGURE_OPTS)        \
-               ./waf configure                 \
+               $(HOST_DIR)/usr/bin/python2 ./waf configure \
                --prefix=/usr                   \
                --disable-libnotify             \
        )
 endef
 
 define MIDORI_BUILD_CMDS
-       (cd $(@D); ./waf build -j $(PARALLEL_JOBS))
+       (cd $(@D); $(HOST_DIR)/usr/bin/python2 ./waf build -j $(PARALLEL_JOBS))
 endef
 
 define MIDORI_INSTALL_TARGET_CMDS
-       (cd $(@D); ./waf --destdir=$(TARGET_DIR) install)
+       (cd $(@D); $(HOST_DIR)/usr/bin/python2 ./waf --destdir=$(TARGET_DIR) install)
 endef
 
 $(eval $(generic-package))