package/rpm: add missing dependency to openssl
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 16 Nov 2014 22:56:03 +0000 (23:56 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 16 Nov 2014 23:25:01 +0000 (00:25 +0100)
We forcibly enable use of an extrernal openssl in rpm, so we must depend
on it.

openssl is correctly selected from kconfig, but there is no build-time
dependency to it.

It was not an issue so far, because openssl always sorts before rpm, so
gets built before. Unless one wants to just build rpm to debug an
autobuilder failure, that is.

Add that build-time dependency to openssl.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/rpm/rpm.mk

index af1642fb8711efa9e432f8cb72a52b3882674cc2..50e6d750300f180fe7964e71e520fc4963ec670a 100644 (file)
@@ -7,7 +7,7 @@
 RPM_VERSION_MAJOR = 5.2
 RPM_VERSION = $(RPM_VERSION_MAJOR).0
 RPM_SITE = http://rpm5.org/files/rpm/rpm-$(RPM_VERSION_MAJOR)
-RPM_DEPENDENCIES = zlib beecrypt neon popt
+RPM_DEPENDENCIES = zlib beecrypt neon popt openssl
 RPM_LICENSE = LGPLv2.1
 RPM_LICENSE_FILES = COPYING.LIB