tcl: add a tclsh symlink
authorRichard Genoud <richard.genoud@gmail.com>
Mon, 24 Jun 2013 08:40:55 +0000 (10:40 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Jul 2013 14:20:08 +0000 (16:20 +0200)
tclsh is installed with its version number (tclshx.y) but scripts (like
usb_modeswitch_dispatcher) are calling tclsh, not tclshx.y.

Signed-off-by: Richard Genoud <richard.genoud@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/tcl/tcl.mk

index cc0565c0daa69e0fc66b1ce4876112811e28648e..c145f57c2394e10a6fedafd4e435b6dbaf58e9a4 100644 (file)
@@ -35,6 +35,11 @@ define TCL_REMOVE_TCLSH
        rm -f $(TARGET_DIR)/usr/bin/tclsh$(TCL_VERSION_MAJOR)
 endef
 TCL_POST_INSTALL_TARGET_HOOKS += TCL_REMOVE_TCLSH
+else
+define TCL_SYMLINK_TCLSH
+       ln -s tclsh$(TCL_VERSION_MAJOR) $(TARGET_DIR)/usr/bin/tclsh
+endef
+TCL_POST_INSTALL_TARGET_HOOKS += TCL_SYMLINK_TCLSH
 endif
 
 $(eval $(autotools-package))