poppler: add explicit libglib2 support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 13 Oct 2016 01:13:55 +0000 (22:13 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 15 Oct 2016 09:34:21 +0000 (11:34 +0200)
Evince needs poppler-glib support (when poppler is enabled, for PDF
reading support), so add explicit handling to the package.
And poppler-glib requires cairo output, hence the conditional on both
libglib2 and cairo to enable it.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/poppler/poppler.mk

index 4632d8dd0c187c1eb878244d1510589f56f61711..172c428c6356f5b6c9e030d339f1536e476dd678 100644 (file)
@@ -28,6 +28,13 @@ else
 POPPLER_CONF_OPTS += --enable-cms=none
 endif
 
+ifeq ($(BR2_PACKAGE_CAIRO)$(BR2_PACKAGE_LIBGLIB2),yy)
+POPPLER_CONF_OPTS += --enable-poppler-glib
+POPPLER_DEPENDENCIES += libglib2
+else
+POPPLER_CONF_OPTS += --disable-poppler-glib
+endif
+
 ifeq ($(BR2_PACKAGE_TIFF),y)
 POPPLER_CONF_OPTS += --enable-libtiff
 # Help poppler to find libtiff in static linking scenarios