apply-patches.sh: Go back to only warn about unsupported file types
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 Sep 2013 20:42:47 +0000 (22:42 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 Sep 2013 20:51:40 +0000 (22:51 +0200)
Fixes http://autobuild.buildroot.net/results/868/8687be8ec029486d9c5e2224cde542134f72884b/

The recent (d245fbb41dc: apply-patches.sh: detect missing patches)
change to apply-patches.sh causes a number of regressions with packages
using downloadable tarballs of patches (typically from Debian), as
those contain additional files besides just the patches (ChangeLog's,
debian/rules, ..).

This use case is arguably abusing the _PATCH handling, but it used to
work so people might rely on it so go back to only warn about this
instead of erroring out.

At the same time reword the warning message.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
support/scripts/apply-patches.sh

index 656aa716c1a4c548ce6a70f57aadefc851be06cf..1ebaea990f09aa1681bb937a2134d755b3a744e4 100755 (executable)
@@ -73,8 +73,8 @@ function apply_patch {
        *.patch*)
        type="patch"; uncomp="cat"; ;;
        *)
-       echo "Unsupported format file for ${path}/${patch}";
-       exit 1;
+       echo "Unsupported file type for ${path}/${patch}, skipping";
+       return 0
        ;;
     esac
     echo ""