gst-plugins-ugly: fix dependencies for mad MP3 decoder plug-in
authorSven Neumann <s.neumann@raumfeld.com>
Fri, 15 Jul 2011 22:33:00 +0000 (00:33 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Jul 2011 21:11:17 +0000 (23:11 +0200)
The mad plug-in depends on libid3tag. This dependency used to be
implicit by selecting the id3tag plug-in. Now that this plug-in
is not any longer part of gst-plugins-ugly we need an explicit
dependency on libid3tag.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-ugly/Config.in
package/multimedia/gst-plugins-ugly/gst-plugins-ugly.mk

index e20426f1b895fac4cfdc259c8d0d0a2dcd354336..94e2b9d554e23332211555b65694798ed5600d96 100644 (file)
@@ -40,7 +40,7 @@ comment "plugins with external dependencies (there may be more available)"
 
 config BR2_PACKAGE_GST_PLUGINS_UGLY_PLUGIN_MAD
        bool "mad (*.mp3 audio)"
-       select BR2_PACKAGE_GST_PLUGINS_UGLY_PLUGIN_ID3TAG
+       select BR2_PACKAGE_LIBID3TAG
        select BR2_PACKAGE_LIBMAD
 
 config BR2_PACKAGE_GST_PLUGINS_UGLY_PLUGIN_MPEG2DEC
index da214a194a463b3c78cd5268233d08c961acf7bd..ab557a386d37861e7b53ee74ec8d587a5653946c 100644 (file)
@@ -62,7 +62,7 @@ endif
 
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_UGLY_PLUGIN_MAD),y)
 GST_PLUGINS_UGLY_CONF_OPT += --enable-mad
-GST_PLUGINS_UGLY_DEPENDENCIES += libmad
+GST_PLUGINS_UGLY_DEPENDENCIES += libid3tag libmad
 else
 GST_PLUGINS_UGLY_CONF_OPT += --disable-mad
 endif