package/qemu: remove host-python dependency.
authorAdam Duskett <Aduskett@gmail.com>
Mon, 4 Feb 2019 12:43:23 +0000 (07:43 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 4 Feb 2019 13:00:19 +0000 (14:00 +0100)
Now that Buildroot requires python >= 2.7, qemu no longer needs a
host-python, as it does not use any external Python modules to build.

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/qemu/qemu.mk

index 3f51e88e1c048dcf2452e547c7bbea7adf05eb8d..30cd5972efd92cdeec24948a9abd77af8bbbd5f8 100644 (file)
@@ -16,7 +16,7 @@ QEMU_LICENSE_FILES = COPYING COPYING.LIB
 #-------------------------------------------------------------
 # Target-qemu
 
-QEMU_DEPENDENCIES = host-pkgconf host-python libglib2 zlib pixman
+QEMU_DEPENDENCIES = host-pkgconf libglib2 zlib pixman
 
 # Need the LIBS variable because librt and libm are
 # not automatically pulled. :-(
@@ -24,9 +24,7 @@ QEMU_LIBS = -lrt -lm
 
 QEMU_OPTS =
 
-QEMU_VARS = \
-       LIBTOOL=$(HOST_DIR)/bin/libtool \
-       PYTHON=$(HOST_DIR)/bin/python2
+QEMU_VARS = LIBTOOL=$(HOST_DIR)/bin/libtool
 
 # If we want to specify only a subset of targets, we must still enable all
 # of them, so that QEMU properly builds its list of default targets, from
@@ -156,7 +154,7 @@ $(eval $(generic-package))
 #-------------------------------------------------------------
 # Host-qemu
 
-HOST_QEMU_DEPENDENCIES = host-pkgconf host-python host-zlib host-libglib2 host-pixman
+HOST_QEMU_DEPENDENCIES = host-pkgconf host-zlib host-libglib2 host-pixman
 
 #       BR ARCH         qemu
 #       -------         ----
@@ -273,7 +271,6 @@ define HOST_QEMU_CONFIGURE_CMDS
                --interp-prefix=$(STAGING_DIR) \
                --cc="$(HOSTCC)" \
                --host-cc="$(HOSTCC)" \
-               --python=$(HOST_DIR)/bin/python2 \
                --extra-cflags="$(HOST_CFLAGS)" \
                --extra-ldflags="$(HOST_LDFLAGS)" \
                $(HOST_QEMU_OPTS)