legal-info: rename legal-warning-pkg-savednothing helper
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 22 Jun 2014 12:41:15 +0000 (14:41 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 22 Jun 2014 20:04:56 +0000 (22:04 +0200)
This helper was called when none of the sources or license
files were saved.

Now we handle license files separately from the sources,
this is no longer the case: they are only called when the
sources are not saved.

Rename the handler and change the warning message accordingly.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Luca Ceresoli <luca@lucaceresoli.net>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Fabio Porcedda <fabio.porcedda@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk
package/pkg-utils.mk

index 851ae0f4ab0bcaa0d2d793cd4051cc3673ab97bf..78fe1346ce8b7f870eebf63e76e961e7c0456b2a 100644 (file)
@@ -662,10 +662,10 @@ endif # license files
 
 ifeq ($$($(2)_SITE_METHOD),local)
 # Packages without a tarball: don't save and warn
-       @$$(call legal-warning-pkg-savednothing,$$($(2)_RAWNAME),local)
+       @$$(call legal-warning-nosource,$$($(2)_RAWNAME),local)
 
 else ifneq ($$($(2)_OVERRIDE_SRCDIR),)
-       @$$(call legal-warning-pkg-savednothing,$$($(2)_RAWNAME),override)
+       @$$(call legal-warning-nosource,$$($(2)_RAWNAME),override)
 
 else
 # Other packages
index 163ef8a07c4a0fc46f9b4d6f4511acf62afe339c..59a5ab2cc252b0d77386ac13163caaddad0573c7 100644 (file)
@@ -101,8 +101,8 @@ define legal-warning-pkg # pkg, text
        echo "WARNING: $(1): $(2)" >>$(LEGAL_WARNINGS)
 endef
 
-define legal-warning-pkg-savednothing # pkg, {local|override}
-       $(call legal-warning-pkg,$(1),sources and license files not saved ($(2) packages not handled))
+define legal-warning-nosource # pkg, {local|override}
+       $(call legal-warning-pkg,$(1),sources not saved ($(2) packages not handled))
 endef
 
 define legal-manifest # pkg, version, license, license-files, source, {HOST|TARGET}