- generalize the menuconfig linux kernel support
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 30 Jan 2007 00:58:18 +0000 (00:58 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 30 Jan 2007 00:58:18 +0000 (00:58 -0000)
- simplify toplevel mkdir rules a tiny bit

Makefile
target/device/Config.in
target/device/x86/Config.in
target/device/x86/Makefile.in

index fb1716638eab3de83905488a4245c631a681058c..7a0253b5bcb121069d933e0d44d8132361bd50b0 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -88,14 +88,8 @@ dirs: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR)
 # dependencies anywhere else
 #
 #############################################################
-$(DL_DIR):
-       @mkdir -p $(DL_DIR)
-
-$(BUILD_DIR):
-       @mkdir -p $(BUILD_DIR)
-
-$(TOOL_BUILD_DIR):
-       @mkdir -p $(TOOL_BUILD_DIR)
+$(DL_DIR) $(BUILD_DIR) $(TOOL_BUILD_DIR):
+       @mkdir -p $@
 
 $(STAGING_DIR):
        @mkdir -p $(STAGING_DIR)/lib
index d4d58ba1e68e8fbd5050ca7b86d978268f2cc7ba..788822f0c250a7e70dd00bcf53ede6be5bf68a5b 100644 (file)
@@ -1,5 +1,20 @@
 menu "Board Support Options"
 
+config BR2_TARGET_GENERIC
+       bool "linux kernel"
+       default n
+       select BR2_PACKAGE_LINUX
+       help
+         Architecture or board dependant linux kernel.
+
+config BR2_PACKAGE_LINUX
+       bool "linux"
+       default n
+       depends BR2_TARGET_GENERIC
+       help
+         The Linux kernel.
+         http://www.kernel.org/
+
 source "target/device/AMD/Config.in"
 source "target/device/Atmel/Config.in"
 source "target/device/Hitachi/Config.in"
index 99887b622dff4e784ed1aa94f83df26047bb5e41..63079534716ef65c6909e0719e78a88a98aa7f00 100644 (file)
@@ -1,22 +1,6 @@
 comment "Generic x86 Device Support"
        depends BR2_i386
 
-config BR2_TARGET_X86_GENERIC
-       bool "Generic x86 support"
-       depends BR2_i386
-       default n
-       select BR2_PACKAGE_LINUX
-       help
-         Generic x86 support.
-
 comment "Package support"
        depends BR2_TARGET_AMD_ALCHEMY
 
-config BR2_PACKAGE_LINUX
-       bool "linux"
-       default n
-       depends BR2_TARGET_X86_GENERIC
-       help
-         The Linux kernel.
-         http://www.kernel.org/
-
index 92a1cf6f368b14d21378638aa600a698a775e69f..b64e73205128177b73829953f83065734fcb00ea 100644 (file)
@@ -1,3 +1,3 @@
-ifeq ($(strip $(BR2_TARGET_X86_GENERIC)),y)
+ifeq ($(strip $(BR2_TARGET_GENERIC)),y)
 include target/device/x86/i386/Makefile.in
 endif