package: rename DISABLE_NLS to NLS_OPTS
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 14:47:48 +0000 (16:47 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 17:09:53 +0000 (19:09 +0200)
We are going to use DISABLE_NLS not only for disabling NLS support,
but also to explicitly enable it. Therefore, this preparatory commit
renames it to NLS_OPTS, which is consistent with other foo_OPTS
variables defined in package/Makefile.in.

While at it, we replace the := assignments by regular = assignments.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in
package/pkg-autotools.mk

index 8087bde999c09c0148eef2ef5fc066243ba4ad04..4a5b3afd321f6dc149b461766400f789d88e851d 100644 (file)
@@ -360,9 +360,9 @@ TARGET_CONFIGURE_ARGS = \
 ################################################################################
 
 ifeq ($(BR2_ENABLE_LOCALE),y)
-DISABLE_NLS :=
+NLS_OPTS =
 else
-DISABLE_NLS :=--disable-nls
+NLS_OPTS = --disable-nls
 endif
 
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
index e215382d069318f69e8b1d6372ff39f577d46701..ba1f4d9764e81d8fb0031ba2b09764736d70910d 100644 (file)
@@ -201,7 +201,7 @@ define $(2)_CONFIGURE_CMDS
                --with-fop=no \
                $$(if $$($$(PKG)_OVERRIDE_SRCDIR),,--disable-dependency-tracking) \
                --enable-ipv6 \
-               $$(DISABLE_NLS) \
+               $$(NLS_OPTS) \
                $$(SHARED_STATIC_LIBS_OPTS) \
                $$(QUIET) $$($$(PKG)_CONF_OPTS) \
        )