libroxml: drop -Werror from CFLAGS
authorPeter Korsgaard <jacmet@sunsite.dk>
Fri, 29 Jul 2011 07:52:59 +0000 (09:52 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 29 Jul 2011 07:52:59 +0000 (09:52 +0200)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libroxml/libroxml-2.1.0-werror.patch [new file with mode: 0644]

diff --git a/package/libroxml/libroxml-2.1.0-werror.patch b/package/libroxml/libroxml-2.1.0-werror.patch
new file mode 100644 (file)
index 0000000..a72f2a7
--- /dev/null
@@ -0,0 +1,22 @@
+[PATCH] remove -Werror from CFLAGS
+
+-Werror should only be used during development, not in released SW.
+
+Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+ Makefile |    2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+Index: libroxml-2.1.0/Makefile
+===================================================================
+--- libroxml-2.1.0.orig/Makefile
++++ libroxml-2.1.0/Makefile
+@@ -41,7 +41,7 @@
+ # options
+ override CPPFLAGS += -Iinc/
+-override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused -Werror -Iinc/ $(DEFINES)
++override CFLAGS += $(OPTIM) -fPIC -Wall -Wextra -Wno-unused -Iinc/ $(DEFINES)
+ override LDFLAGS += 
+ ifeq ("$(OS)", "Darwin")