collectd: add notify_nagios plugin support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Thu, 22 Dec 2016 01:59:09 +0000 (22:59 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 23 Dec 2016 21:32:21 +0000 (22:32 +0100)
Add explicit support for the new notify_nagios dependency-less plugin.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/collectd/Config.in
package/collectd/collectd.mk

index 6405af6a892393a9810135099951a3aa86de0921..72e57931a59a435d69df36e993250917234d61d8 100644 (file)
@@ -75,6 +75,11 @@ config BR2_PACKAGE_COLLECTD_NOTIFY_EMAIL
 comment "notify_email needs a toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS
 
+config BR2_PACKAGE_COLLECTD_NOTIFY_NAGIOS
+       bool "notify_nagios"
+       help
+         Sends notifications to Nagios as a passive check result.
+
 config BR2_PACKAGE_COLLECTD_SYSLOG
        bool "syslog"
        default y
index ccb2f1133eb242cbc17dfc0b94f327622a0709d4..942ba388931679839435f66643baa6237a4acd96 100644 (file)
@@ -77,6 +77,7 @@ COLLECTD_CONF_OPTS += \
        $(if $(BR2_PACKAGE_COLLECTD_NGINX),--enable-nginx,--disable-nginx) \
        $(if $(BR2_PACKAGE_COLLECTD_NOTIFICATION),--enable-target_notification,--disable-target_notification) \
        $(if $(BR2_PACKAGE_COLLECTD_NOTIFY_EMAIL),--enable-notify_email,--disable-notify_email) \
+       $(if $(BR2_PACKAGE_COLLECTD_NOTIFY_NAGIOS),--enable-notify_nagios,--disable-notify_nagios) \
        $(if $(BR2_PACKAGE_COLLECTD_NTPD),--enable-ntpd,--disable-ntpd) \
        $(if $(BR2_PACKAGE_COLLECTD_OLSRD),--enable-olsrd,--disable-olsrd) \
        $(if $(BR2_PACKAGE_COLLECTD_OPENLDAP),--enable-openldap,--disable-openldap) \