package infra: revert 0a4bd19f
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Sun, 25 May 2014 22:12:59 +0000 (19:12 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Jul 2014 18:25:10 +0000 (20:25 +0200)
Revert commit 0a4bd19f4a136930c611027942ce43124a81c5cb
Using --static is not documented and actually breaks static linking
according to my tests.
Fixes:
http://autobuild.buildroot.net/results/327/327c18db4e5d0ddc2c72a4684e103c19a1405e50/
...for external toolchains

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Makefile.in

index fc558500658b6fc6366de778dbaad5aada9dc5a8..427c6d84d79c9460307060039525faa66ae242dc 100644 (file)
@@ -374,7 +374,7 @@ endif
 
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
 SHARED_STATIC_LIBS_OPTS = --enable-static --disable-shared
-TARGET_LDFLAGS += --static
+TARGET_LDFLAGS += -static
 else
 SHARED_STATIC_LIBS_OPTS = --enable-static --enable-shared
 endif