package/python-cheetah: bump to version 3.2.4
authorYegor Yefremov <yegorslists@googlemail.com>
Thu, 19 Mar 2020 10:53:34 +0000 (11:53 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 21 Mar 2020 14:22:45 +0000 (15:22 +0100)
The original python-cheetah project was abandoned and a new
fork was created as a drop-in replacement. Though the name of the
fork is Cheetah3, we do not rename the package name to avoid
dependency renaming.

The new fork supports both Python2 and Python3.

python-markdown is now an optional dependency.

Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/python-cheetah/Config.in
package/python-cheetah/python-cheetah.hash
package/python-cheetah/python-cheetah.mk

index 12749a1681887363dcd266bf0f36026b94135fbb..7cbfc5c2519632eecee5054e57f67c6eeef97e79 100644 (file)
@@ -1,13 +1,12 @@
 config BR2_PACKAGE_PYTHON_CHEETAH
        bool "python-cheetah"
-       depends on BR2_PACKAGE_PYTHON
        help
          Cheetah is an open source template engine and code
          generation tool.
 
          It can be used standalone or combined with other tools and
-         frameworks.  Web development is its principle use, but
+         frameworks. Web development is its principle use, but
          Cheetah is very flexible and is also being used to generate
          C++ game code, Java, sql, form emails and even Python code.
 
-         https://pypi.python.org/pypi/Cheetah/
+         https://pypi.org/project/Cheetah3/
index 477ee5483a8bc238cab3611189de66e66cc2bdeb..286b41fd9ecffe67606e926871dc34848a71a1fc 100644 (file)
@@ -1,4 +1,5 @@
-# From https://pypi.python.org/pypi/Cheetah/2.4.4
-md5    853917116e731afbc8c8a43c37e6ddba        Cheetah-2.4.4.tar.gz
-# Calculated based on the hash above
-sha256 be308229f0c1e5e5af4f27d7ee06d90bb19e6af3059794e5fd536a6f29a9b550        Cheetah-2.4.4.tar.gz
+# From https://pypi.org/pypi/Cheetah3/json
+md5  8c0ac643263ffc3454fb321342284d0a  Cheetah3-3.2.4.tar.gz
+sha256 caabb9c22961a3413ac85cd1e5525ec9ca80daeba6555f4f60802b6c256e252b  Cheetah3-3.2.4.tar.gz
+# Locally computed sha256 checksums
+sha256  635349ae512fafc2e60eb74a50d0a5276fa06c00b5ecb20da53546449ddc45ea  LICENSE
index eee87fcee79596972ec73399f8471a108b489bb1..1ad49a43b77692d5980a77af9dced34008f9af79 100644 (file)
@@ -4,17 +4,12 @@
 #
 ################################################################################
 
-PYTHON_CHEETAH_VERSION = 2.4.4
-PYTHON_CHEETAH_SOURCE = Cheetah-$(PYTHON_CHEETAH_VERSION).tar.gz
-PYTHON_CHEETAH_SITE = https://pypi.python.org/packages/source/C/Cheetah
+PYTHON_CHEETAH_VERSION = 3.2.4
+PYTHON_CHEETAH_SOURCE = Cheetah3-$(PYTHON_CHEETAH_VERSION).tar.gz
+PYTHON_CHEETAH_SITE = https://files.pythonhosted.org/packages/4e/72/e6a7d92279e3551db1b68fd336fd7a6e3d2f2ec742bf486486e6150d77d2
 PYTHON_CHEETAH_LICENSE = MIT
+PYTHON_CHEETAH_LICENSE_FILES = LICENSE
 PYTHON_CHEETAH_SETUP_TYPE = setuptools
 
-HOST_PYTHON_CHEETAH_NEEDS_HOST_PYTHON = python2
-
-# The dependency on host-python-markdown is needed to prevent
-# setuptools from downloading markdown if it is not installed yet.
-HOST_PYTHON_CHEETAH_DEPENDENCIES = host-python-markdown
-
 $(eval $(python-package))
 $(eval $(host-python-package))