qt5multimedia: conditionally add alsa-lib to dependencies
authorBartosz Golaszewski <brgl@bgdev.pl>
Tue, 27 Jun 2017 07:53:09 +0000 (09:53 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Jul 2017 17:04:28 +0000 (19:04 +0200)
Qt5Multimedia builds the alsa plugin if it detects libasound in the
system. Add alsa-lib to dependencies if BR2_PACKAGE_ALSA_LIB is
selected.

Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl>
Reviewed-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/qt5/qt5multimedia/qt5multimedia.mk

index 19312ff29d69d9a2e5f37087b3032c9b0c1a6138..062d980a050f7705056f077405041e1c940eb594 100644 (file)
@@ -30,6 +30,10 @@ ifeq ($(BR2_PACKAGE_LIBGLIB2)$(BR2_PACKAGE_PULSEAUDIO),yy)
 QT5MULTIMEDIA_DEPENDENCIES += libglib2 pulseaudio
 endif
 
+ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
+QT5MULTIMEDIA_DEPENDENCIES += alsa-lib
+endif
+
 define QT5MULTIMEDIA_CONFIGURE_CMDS
        (cd $(@D); $(TARGET_MAKE_ENV) $(HOST_DIR)/usr/bin/qmake)
 endef