util-linux: add optional dependency on audit
authorRahul Bedarkar <rahul.bedarkar@imgtec.com>
Thu, 15 Sep 2016 10:27:03 +0000 (15:57 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Fri, 16 Sep 2016 16:43:09 +0000 (18:43 +0200)
login and hwclock can be built with audit support. This patch adds
optional dependency on audit package if it is already selected.

Signed-off-by: Rahul Bedarkar <rahul.bedarkar@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/util-linux/util-linux.mk

index 7b16ca40a24ad3c532acc9d5836acd166bfa8c3d..82230bca77fcd3bd56ef5d726f48be6f9d7a5357 100644 (file)
@@ -153,6 +153,13 @@ else
 UTIL_LINUX_CONF_OPTS += --without-readline
 endif
 
+ifeq ($(BR2_PACKAGE_AUDIT),y)
+UTIL_LINUX_CONF_OPTS += --with-audit
+UTIL_LINUX_DEPENDENCIES += audit
+else
+UTIL_LINUX_CONF_OPTS += --without-audit
+endif
+
 # Install PAM configuration files
 ifeq ($(BR2_PACKAGE_UTIL_LINUX_LOGIN_UTILS),y)
 define UTIL_LINUX_INSTALL_PAMFILES