package/bdwgc: bump version to 7.6.2
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 7 Jan 2018 19:08:31 +0000 (20:08 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 7 Jan 2018 20:28:37 +0000 (21:28 +0100)
Removed patches applied upstream:

0002-Fix-uClibc-build.patch
https://github.com/ivmai/bdwgc/commit/047230b71d421407ad2c8641ee4a87a1bd89145b

0003-configure-match-uclinux-pattern.patch
https://github.com/ivmai/bdwgc/commit/a628c90bdbf397465ac2ab2b11f14eb2e853651c

Renumbered remaining patches, added license hash.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/bdwgc/0002-Fix-size-of-tv-is-unknown-error-in-brief_async_signa.patch [new file with mode: 0644]
package/bdwgc/0002-Fix-uClibc-build.patch [deleted file]
package/bdwgc/0003-Fix-size-of-tv-is-unknown-error-in-brief_async_signa.patch [deleted file]
package/bdwgc/0003-configure-match-uclinux-pattern.patch [deleted file]
package/bdwgc/bdwgc.hash
package/bdwgc/bdwgc.mk

diff --git a/package/bdwgc/0002-Fix-size-of-tv-is-unknown-error-in-brief_async_signa.patch b/package/bdwgc/0002-Fix-size-of-tv-is-unknown-error-in-brief_async_signa.patch
new file mode 100644 (file)
index 0000000..e17ed84
--- /dev/null
@@ -0,0 +1,35 @@
+From 31eef02317d59b4d204624efbddaea641e861390 Mon Sep 17 00:00:00 2001
+From: Mikael Djurfeldt <mikael@djurfeldt.com>
+Date: Sun, 26 Feb 2017 20:09:56 +0100
+Subject: [PATCH] Fix 'size of tv is unknown' error in
+ brief_async_signal_safe_sleep (musl) (fix commits 62097c3, 9f48082)
+
+Include <sys/time.h> to get struct timeval defined and select() declared.
+
+* pthread_stop_world.c [GC_ENABLE_SUSPEND_THREAD]: Include sys/time.h
+before GC_brief_async_signal_safe_sleep definition.
+
+Upstream status: upstream
+commit ffad61d3bbe86c09ffe062dab393fcb0e4940580
+
+[Romain: backported to 7.6.0]
+Signed-off-by: Romain Naour <romain.naour@gmail.com>
+---
+ pthread_stop_world.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pthread_stop_world.c b/pthread_stop_world.c
+index dad1fdc..8c76944 100644
+--- a/pthread_stop_world.c
++++ b/pthread_stop_world.c
+@@ -391,6 +391,7 @@ STATIC void GC_restart_handler(int sig)
+ #   ifndef GC_TIME_LIMIT
+ #     define GC_TIME_LIMIT 50
+ #   endif
++#   include <sys/time.h>
+     STATIC void GC_brief_async_signal_safe_sleep(void)
+     {
+-- 
+2.9.4
+
diff --git a/package/bdwgc/0002-Fix-uClibc-build.patch b/package/bdwgc/0002-Fix-uClibc-build.patch
deleted file mode 100644 (file)
index 55896eb..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-From 8d3caf00db5d71ec19f03fbf96cecf6f70b4e868 Mon Sep 17 00:00:00 2001
-From: Bernd Kuhls <bernd.kuhls@t-online.de>
-Date: Sun, 28 May 2017 20:21:09 +0200
-Subject: [PATCH] Fix uClibc build
-
-uClibc defines __GLIBC__ but does not contain libc-version.h leading to
-a build error:
-
-./include/private/gcconfig.h:1426:72: fatal error: gnu/libc-version.h: No such file or directory
-
-Patch sent upstream: https://github.com/ivmai/bdwgc/pull/164
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- include/private/gcconfig.h | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/include/private/gcconfig.h b/include/private/gcconfig.h
-index d7912e9e..bf17dd63 100644
---- a/include/private/gcconfig.h
-+++ b/include/private/gcconfig.h
-@@ -1442,7 +1442,7 @@
- #         define GC_PREFETCH_FOR_WRITE(x) \
-             __asm__ __volatile__ ("prefetchw %0" : : "m"(*(char *)(x)))
- #       endif
--#       if defined(__GLIBC__)
-+#       if defined(__GLIBC__) && !defined(__UCLIBC__)
-           /* Workaround lock elision implementation for some glibc.     */
- #         define GLIBC_2_19_TSX_BUG
- #         include <gnu/libc-version.h> /* for gnu_get_libc_version() */
-@@ -2455,7 +2455,7 @@
-           /* FIXME: This seems to be fixed in GLibc v2.14.              */
- #         define GETCONTEXT_FPU_EXCMASK_BUG
- #       endif
--#       if defined(__GLIBC__)
-+#       if defined(__GLIBC__) && !defined(__UCLIBC__)
-           /* Workaround lock elision implementation for some glibc.     */
- #         define GLIBC_2_19_TSX_BUG
- #         include <gnu/libc-version.h> /* for gnu_get_libc_version() */
--- 
-2.11.0
-
diff --git a/package/bdwgc/0003-Fix-size-of-tv-is-unknown-error-in-brief_async_signa.patch b/package/bdwgc/0003-Fix-size-of-tv-is-unknown-error-in-brief_async_signa.patch
deleted file mode 100644 (file)
index e17ed84..0000000
+++ /dev/null
@@ -1,35 +0,0 @@
-From 31eef02317d59b4d204624efbddaea641e861390 Mon Sep 17 00:00:00 2001
-From: Mikael Djurfeldt <mikael@djurfeldt.com>
-Date: Sun, 26 Feb 2017 20:09:56 +0100
-Subject: [PATCH] Fix 'size of tv is unknown' error in
- brief_async_signal_safe_sleep (musl) (fix commits 62097c3, 9f48082)
-
-Include <sys/time.h> to get struct timeval defined and select() declared.
-
-* pthread_stop_world.c [GC_ENABLE_SUSPEND_THREAD]: Include sys/time.h
-before GC_brief_async_signal_safe_sleep definition.
-
-Upstream status: upstream
-commit ffad61d3bbe86c09ffe062dab393fcb0e4940580
-
-[Romain: backported to 7.6.0]
-Signed-off-by: Romain Naour <romain.naour@gmail.com>
----
- pthread_stop_world.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/pthread_stop_world.c b/pthread_stop_world.c
-index dad1fdc..8c76944 100644
---- a/pthread_stop_world.c
-+++ b/pthread_stop_world.c
-@@ -391,6 +391,7 @@ STATIC void GC_restart_handler(int sig)
- #   ifndef GC_TIME_LIMIT
- #     define GC_TIME_LIMIT 50
- #   endif
-+#   include <sys/time.h>
-     STATIC void GC_brief_async_signal_safe_sleep(void)
-     {
--- 
-2.9.4
-
diff --git a/package/bdwgc/0003-configure-match-uclinux-pattern.patch b/package/bdwgc/0003-configure-match-uclinux-pattern.patch
deleted file mode 100644 (file)
index b2c6198..0000000
+++ /dev/null
@@ -1,27 +0,0 @@
-From a628c90bdbf397465ac2ab2b11f14eb2e853651c Mon Sep 17 00:00:00 2001
-From: Romain Naour <romain.naour@gmail.com>
-Date: Sat, 6 Aug 2016 23:24:35 +0200
-Subject: [PATCH] configure: match uclinux pattern
-
-BDWGC does not recognize "uclinux" as a valid OS part of the target
-tuple which is used by some arm cortex-M toolchains.
-
-* configure.ac [$THREADS=pthreads] (GC_LINUX_THREADS, _REENTRANT): Define
-for hosts matching "*-*-*linux*" (instead of "*-*-linux*").
----
- configure.ac | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/configure.ac b/configure.ac
-index 22353547..fa745b56 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -190,7 +190,7 @@ case "$THREADS" in
-         AC_DEFINE(THREAD_LOCAL_ALLOC)
-         AC_MSG_WARN("Explicit GC_INIT() calls may be required.");
-         ;;
--     *-*-linux* | *-*-nacl*)
-+     *-*-*linux* | *-*-nacl*)
-         AC_DEFINE(GC_LINUX_THREADS)
-         AC_DEFINE(_REENTRANT)
-         ;;
index 4b41e1d85b7ce447d745de7af082dfaf598296c6..0ebc41c76d076e61f6e54af0a1812b44d1224d02 100644 (file)
@@ -1,2 +1,3 @@
 # Locally computed
-sha256 a14a28b1129be90e55cd6f71127ffc5594e1091d5d54131528c24cd0c03b7d90  gc-7.6.0.tar.gz
+sha256 bd112005563d787675163b5afff02c364fc8deb13a99c03f4e80fdf6608ad41e  gc-7.6.2.tar.gz
+sha256 9944acfcee6cca308d974933977c1608804f5ad4345aac7cb8608137104e3742  README.QUICK
index e148f7223b4d55cea81e91c0eac74580c17a86b3..5603df8d9de12f6c089119bf8abc8529428467e4 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-BDWGC_VERSION = 7.6.0
+BDWGC_VERSION = 7.6.2
 BDWGC_SOURCE = gc-$(BDWGC_VERSION).tar.gz
 BDWGC_SITE = http://www.hboehm.info/gc/gc_source
 BDWGC_INSTALL_STAGING = YES