package/gobject-introspection: fix --includedir
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Wed, 1 Sep 2021 19:13:06 +0000 (21:13 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 14:50:43 +0000 (16:50 +0200)
Set includedir to $(STAGING_DIR)/usr/share/gir-1.0 instead of . in
Makefile.introspection or g-ir-compiler won't find .gir files resulting
in a build failure for autotools-based based programs such as gconf
since bump of gobject-introspection to version 1.68.0 in commit
abc110e3624aa4e8a9bd8595b3fdc0aec60845e0:

Could not find GIR file 'GObject-2.0.gir'; check XDG_DATA_DIRS or use --includedir
error parsing file GConf-2.0.gir: Failed to parse included gir GObject-2.0

Fixes:
 - http://autobuild.buildroot.org/results/8180d893cbd27512915a7f8a3adb232b93a98ceb

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/gobject-introspection/gobject-introspection.mk

index 81938b14dff3734fdfce851ea7f9a2addd718698..f34dca7278a5df43f52dfbc132e0dcb3d68fd5cc 100644 (file)
@@ -133,6 +133,12 @@ define GOBJECT_INTROSPECTION_INSTALL_WRAPPERS
 
        $(SED) "s%typelibdir=.*%typelibdir=\$${prefix}/lib/girepository-1.0%g" \
                $(STAGING_DIR)/usr/lib/pkgconfig/gobject-introspection-1.0.pc
+
+       # Set includedir to $(STAGING_DIR)/usr/share/gir-1.0 instead of . or
+       # g-ir-compiler won't find .gir files resulting in a build failure for
+       # autotools-based based programs
+       $(SED) "s%includedir=.%includedir=$(STAGING_DIR)/usr/share/gir-1.0%g" \
+               $(STAGING_DIR)/usr/share/gobject-introspection-1.0/Makefile.introspection
 endef
 GOBJECT_INTROSPECTION_POST_INSTALL_STAGING_HOOKS += GOBJECT_INTROSPECTION_INSTALL_WRAPPERS