toolchain: do not check largefile, wchar, IPv6 and locale for glibc toolchains
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 8 Oct 2013 18:17:08 +0000 (20:17 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 9 Oct 2013 13:24:45 +0000 (15:24 +0200)
The check_glibc function contained checks to verify that the user had
properly enabled the largefile, IPv6, locale and wchar options, to
match how glibc is configured. This was useful when the support for
glibc external toolchains was introduced, but since then, we added the
BR2_TOOLCHAIN_USES_GLIBC symbol that automatically enables largefile,
IPv6, locale and wchar support when a glibc or eglibc external
toolchain is used. Therefore, many of the check_glibc checks are
useless now, so we can remove these.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
toolchain/helpers.mk

index 0144674185efbfcb23161a3efc968f095f1b448a..a4a13c732770008742c747d4c3f77f6f376ce15f 100644 (file)
@@ -205,11 +205,7 @@ check_glibc = \
                echo "Incorrect selection of the C library"; \
                exit -1; \
        fi; \
-       $(call check_glibc_feature,BR2_LARGEFILE,Large file support) ;\
-       $(call check_glibc_feature,BR2_INET_IPV6,IPv6 support) ;\
-       $(call check_glibc_feature,BR2_ENABLE_LOCALE,Locale support) ;\
        $(call check_glibc_feature,BR2_USE_MMU,MMU support) ;\
-       $(call check_glibc_feature,BR2_USE_WCHAR,Wide char support) ;\
        $(call check_glibc_rpc_feature,$${SYSROOT_DIR})
 
 #