be sure include dir is present
authorEric Andersen <andersen@codepoet.org>
Fri, 17 Jan 2003 04:50:35 +0000 (04:50 -0000)
committerEric Andersen <andersen@codepoet.org>
Fri, 17 Jan 2003 04:50:35 +0000 (04:50 -0000)
make/openssl.mk

index 15948c06662f113fc97682714a00bf17d422512c..183781ee5ee46935d4d6219674d99bd5e94a6b05 100644 (file)
@@ -43,6 +43,7 @@ $(TARGET_DIR)/lib/libcrypto.so.0: $(STAGING_DIR)/lib/libcrypto.so.0
        #cp -fa $(STAGING_DIR)/bin/openssl  $(TARGET_DIR)/bin/
 
 $(TARGET_DIR)/usr/include/openssl/crypto.h: $(TARGET_DIR)/lib/libcrypto.so.0
+       mkdir -p $(TARGET_DIR)/usr/include 
        cp -a $(STAGING_DIR)/include/openssl $(TARGET_DIR)/usr/include/
        cp -dpf $(STAGING_DIR)/lib/libssl.a $(TARGET_DIR)/usr/lib/
        cp -dpf $(STAGING_DIR)/lib/libcrypto.a $(TARGET_DIR)/usr/lib/