perl-module-runtime: new package
authorChristopher McCrory <chrismcc@gmail.com>
Fri, 10 Aug 2018 16:14:56 +0000 (09:14 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 13 Aug 2018 07:36:30 +0000 (09:36 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-module-runtime/Config.in [new file with mode: 0644]
package/perl-module-runtime/perl-module-runtime.hash [new file with mode: 0644]
package/perl-module-runtime/perl-module-runtime.mk [new file with mode: 0644]

index e88f95127443b413eb32541a0251b2e6f439f9d6..91659b364b12294302c418b4e9fb0986cae12f05 100644 (file)
@@ -491,6 +491,7 @@ F:  package/perl-device-serialport/
 F:     package/perl-file-slurp/
 F:     package/perl-io-interface/
 F:     package/perl-json-maybexs/
+F:     package/perl-module-runtime/
 
 N:     Clayton Shotwell <clayton.shotwell@rockwellcollins.com>
 F:     package/audit/
index 32a567ca2372df2beb408898aff01e5ca90e41f2..4a6fd22238b7ff59fcb0b9fade3a5603b07844a7 100644 (file)
@@ -707,6 +707,7 @@ menu "Perl libraries/modules"
        source "package/perl-mailtools/Config.in"
        source "package/perl-mime-base64-urlsafe/Config.in"
        source "package/perl-mime-base64/Config.in"
+       source "package/perl-module-runtime/Config.in"
        source "package/perl-mojolicious-plugin-authentication/Config.in"
        source "package/perl-mojolicious/Config.in"
        source "package/perl-net-dns/Config.in"
diff --git a/package/perl-module-runtime/Config.in b/package/perl-module-runtime/Config.in
new file mode 100644 (file)
index 0000000..fca29f6
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PERL_MODULE_RUNTIME
+       bool "perl-module-runtime"
+       help
+         runtime module handling
+
+         https://metacpan.org/release/Module-Runtime
diff --git a/package/perl-module-runtime/perl-module-runtime.hash b/package/perl-module-runtime/perl-module-runtime.hash
new file mode 100644 (file)
index 0000000..c52cb75
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    d3d47222fa2e3dfcb4526f6cc8437b20 Module-Runtime-0.016.tar.gz
+sha256 68302ec646833547d410be28e09676db75006f4aa58a11f3bdb44ffe99f0f024 Module-Runtime-0.016.tar.gz
+
+# computed by scancpan
+sha256 ad1761020436687e8493208336ef53e84589fdba212da59b05b8111cca75ddc1 README
diff --git a/package/perl-module-runtime/perl-module-runtime.mk b/package/perl-module-runtime/perl-module-runtime.mk
new file mode 100644 (file)
index 0000000..5ba95f7
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-module-runtime
+#
+################################################################################
+
+PERL_MODULE_RUNTIME_VERSION = 0.016
+PERL_MODULE_RUNTIME_SOURCE = Module-Runtime-$(PERL_MODULE_RUNTIME_VERSION).tar.gz
+PERL_MODULE_RUNTIME_SITE = $(BR2_CPAN_MIRROR)/authors/id/Z/ZE/ZEFRAM
+PERL_MODULE_RUNTIME_DEPENDENCIES = host-perl-module-build
+PERL_MODULE_RUNTIME_LICENSE = Artistic or GPL-1.0+
+PERL_MODULE_RUNTIME_LICENSE_FILES = README
+
+$(eval $(perl-package))