pkg-generic: fix SUBDIR handling
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Jul 2012 07:17:56 +0000 (09:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 24 Jul 2012 07:17:56 +0000 (09:17 +0200)
Commit 9ba9bfb9a02706fa414bcf4c6dcceac1b68a5c9a inverted the logic to
define $(2)_SUBDIR, breaking the build of things using the _SUBDIR
feature, like the tcl package.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-generic.mk

index 8a730c0a0101f206096b95353742ab7b7a61e477..d1f4f2a2ceab8ac7fe490893bef0f7e664509aa7 100644 (file)
@@ -204,11 +204,11 @@ $(2)_BASE_NAME    =  $(1)-$$($(2)_VERSION)
 $(2)_DL_DIR    =  $$(DL_DIR)/$$($(2)_BASE_NAME)
 $(2)_DIR       =  $$(BUILD_DIR)/$$($(2)_BASE_NAME)
 
-ifndef $(3)_SUBDIR
- ifdef $(2)_SUBDIR
-  $(3)_SUBDIR = $$($(2)_SUBDIR)
+ifndef $(2)_SUBDIR
+ ifdef $(3)_SUBDIR
+  $(2)_SUBDIR = $$($(3)_SUBDIR)
  else
-  $(3)_SUBDIR ?=
+  $(2)_SUBDIR ?=
  endif
 endif