package/syslogd: workaround a compiler bug with CS powerpc 2012.03
authorRomain Naour <romain.naour@gmail.com>
Sun, 14 Feb 2016 10:55:13 +0000 (11:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 14 Feb 2016 20:51:19 +0000 (21:51 +0100)
The O3 optimization triggers a compiler bug with this toolchain,
change it with 02.

Fixes:
http://autobuild.buildroot.net/results/2fb/2fb94ecfdc32761a09da35e6fcbdd512847ec911

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/sysklogd/sysklogd.mk

index de2edf409e5728a34ebb4bf780e411a989a0bb14..9e315bcdf316eb6c92bba8ccd7d7ff3b711bb7a2 100644 (file)
@@ -14,6 +14,14 @@ ifeq ($(BR2_PACKAGE_BUSYBOX),y)
 SYSKLOGD_DEPENDENCIES = busybox
 endif
 
+# CS PowerPC 2012.03 triggers compiler bug.
+ifeq ($(BR2_TOOLCHAIN_EXTERNAL_CODESOURCERY_POWERPC_E500V2),y)
+define SYSKLOGD_WORKAROUND_COMPILER_BUG
+       $(SED) 's/-O3/-O2/' $(@D)/Makefile
+endef
+SYSKLOGD_POST_PATCH_HOOKS = SYSKLOGD_WORKAROUND_COMPILER_BUG
+endif
+
 define SYSKLOGD_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
 endef