package/rpi-bt-firmware: bump version
authorMartin Bark <martin@barkynet.com>
Sun, 6 May 2018 20:07:29 +0000 (21:07 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 20 May 2018 10:32:41 +0000 (12:32 +0200)
Signed-off-by: Martin Bark <martin@barkynet.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rpi-bt-firmware/rpi-bt-firmware.hash
package/rpi-bt-firmware/rpi-bt-firmware.mk

index 553a7e4298baecdc8741a4f3b6dda47bb1be67cb..043706a1b8a3ed4f9777e95e3496df48a0b073af 100644 (file)
@@ -1,3 +1,3 @@
 # Locally computed
-sha256 beade89c5c072158b6cf18cf741d2695980fd6a4533dab3897bebf90c0631a30  rpi-bt-firmware-18d7c931aff0a8a78360b9b9eaeb15d1224fb907.tar.gz
+sha256 c219f1d232fb80fbf23e7f2ed97d9c495855355a36dda373a8985c699ee1dd4b  rpi-bt-firmware-b5307312a172c8d87d44f6df32f5e24f1c19770e.tar.gz
 sha256 b16056fc91b82a0e3e8de8f86c2dac98201aa9dc3cbd33e8d38f1b087fcec30d  LICENCE.broadcom_bcm43xx
index bbb40854e8eea940d7400094c9ca8ab8e7cfec7f..b1c0aa7c943bd956e2bb7305bfe65981effa04ab 100644 (file)
@@ -4,17 +4,14 @@
 #
 ################################################################################
 
-RPI_BT_FIRMWARE_VERSION = 18d7c931aff0a8a78360b9b9eaeb15d1224fb907
+RPI_BT_FIRMWARE_VERSION = b5307312a172c8d87d44f6df32f5e24f1c19770e
 RPI_BT_FIRMWARE_SITE = $(call github,LibreELEC,brcmfmac_sdio-firmware-rpi,$(RPI_BT_FIRMWARE_VERSION))
 RPI_BT_FIRMWARE_LICENSE = PROPRIETARY
 RPI_BT_FIRMWARE_LICENSE_FILES = LICENCE.broadcom_bcm43xx
 
-RPI_BT_FIRMWARE_FILES = brcm/BCM43430A1.hcd BCM4345C0.hcd
-
 define RPI_BT_FIRMWARE_INSTALL_TARGET_CMDS
-       $(foreach file,$(RPI_BT_FIRMWARE_FILES),\
-               $(INSTALL) -D -m 0644 $(@D)/firmware/$(file) $(TARGET_DIR)/lib/firmware/$(notdir $(file))
-       )
+       $(INSTALL) -d $(TARGET_DIR)/lib/firmware/brcm
+       $(INSTALL) -m 0644 $(@D)/firmware/brcm/*.hcd $(TARGET_DIR)/lib/firmware/brcm
 endef
 
 $(eval $(generic-package))