msr-tools: new package
authorVincent Stehlé <vincent.stehle@intel.com>
Sun, 28 Feb 2016 21:12:58 +0000 (22:12 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 28 Feb 2016 21:31:04 +0000 (22:31 +0100)
The MSR Tools project provides utilities to access x86 processor MSRs
and CPU ID directly.

https://01.org/msr-tools

Signed-off-by: Vincent Stehlé <vincent.stehle@intel.com>
Cc: Yegor Yefremov <yegorslists@googlemail.com>
Cc: Arnout Vandecappelle <arnout@mind.be>
[Thomas:
 - rewrap Config.in help text
 - use $(TARGET_MAKE_ENV) when calling $(MAKE).]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/msr-tools/Config.in [new file with mode: 0644]
package/msr-tools/msr-tools.hash [new file with mode: 0644]
package/msr-tools/msr-tools.mk [new file with mode: 0644]

index 67a25148e7abe7d2a91e3fcda00f5e943ec86841..03876be5aadded694a0ae54174ed8c5dc89a8a78 100644 (file)
@@ -407,6 +407,7 @@ endif
        source "package/memtest86/Config.in"
        source "package/memtester/Config.in"
        source "package/minicom/Config.in"
+       source "package/msr-tools/Config.in"
        source "package/nanocom/Config.in"
        source "package/neard/Config.in"
        source "package/nvidia-driver/Config.in"
diff --git a/package/msr-tools/Config.in b/package/msr-tools/Config.in
new file mode 100644 (file)
index 0000000..dde19f7
--- /dev/null
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_MSR_TOOLS
+       bool "msr-tools"
+       depends on BR2_i386 || BR2_x86_64
+       help
+         The MSR Tools project provides utilities to access x86
+         processor MSRs and CPU ID directly.
+
+         Those tools access the hardware through the
+         /dev/cpu/<cpu#>/msr and /dev/cpu/<cpu#>/cpuid devices. This
+         necessitates msr and cpuid support in the kernel, which
+         means you need a kernel compiled with configuration options
+         CONFIG_X86_CPUID and CONFIG_X86_MSR enabled.
+
+         https://01.org/msr-tools
diff --git a/package/msr-tools/msr-tools.hash b/package/msr-tools/msr-tools.hash
new file mode 100644 (file)
index 0000000..18146df
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed:
+sha256 9b87245ee091a798184e447066e9e0d7709b7c81f5e6ad55f2b958c1aa50c4a3 msr-tools-1.3.tar.gz
diff --git a/package/msr-tools/msr-tools.mk b/package/msr-tools/msr-tools.mk
new file mode 100644 (file)
index 0000000..4f84a28
--- /dev/null
@@ -0,0 +1,21 @@
+################################################################################
+#
+# msr-tools
+#
+################################################################################
+
+MSR_TOOLS_VERSION = 1.3
+MSR_TOOLS_SITE = $(call github,01org,msr-tools,msr-tools-$(MSR_TOOLS_VERSION))
+MSR_TOOLS_LICENSE = GPLv2
+MSR_TOOLS_LICENSE_FILES = cpuid.c
+
+define MSR_TOOLS_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS)
+endef
+
+define MSR_TOOLS_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) $(TARGET_CONFIGURE_OPTS) install \
+               sbindir="$(TARGET_DIR)/usr/sbin"
+endef
+
+$(eval $(generic-package))