gst-plugins-base: update to new upstream release 0.10.25
authorSven Neumann <s.neumann@raumfeld.com>
Wed, 7 Oct 2009 12:15:23 +0000 (14:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 7 Oct 2009 12:51:26 +0000 (14:51 +0200)
Update gst-plugins-base to version 0.10.25. Also add new
config option to enable/disable the Pango font renderer
plug-in.

Signed-off-by: Sven Neumann <s.neumann@raumfeld.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/multimedia/gst-plugins-base/Config.in
package/multimedia/gst-plugins-base/gst-plugins-base.mk

index 8883a433f3b11d8bb76056b14afbcae68ddaccfe..f08be7eb7685d9bcf8a5864105614ca39237f598 100644 (file)
@@ -72,6 +72,10 @@ config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_OGG
        bool "ogg (*.ogg audio/video)"
        select BR2_PACKAGE_LIBOGG
 
+config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PANGO
+       bool "pango font renderer"
+       select BR2_PACKAGE_PANGO
+
 config BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA
        bool "theora (*.ogg video)"
        select BR2_PACKAGE_LIBTHEORA
index 63f23cd5cdd9e27e844765c6f548753027e25c38..bd422be0f60f1fd60eefb7587a076ea3f593becb 100644 (file)
@@ -3,7 +3,7 @@
 # gst-plugins-base
 #
 #############################################################
-GST_PLUGINS_BASE_VERSION = 0.10.23
+GST_PLUGINS_BASE_VERSION = 0.10.25
 GST_PLUGINS_BASE_SOURCE = gst-plugins-base-$(GST_PLUGINS_BASE_VERSION).tar.bz2
 GST_PLUGINS_BASE_SITE = http://gstreamer.freedesktop.org/src/gst-plugins-base
 GST_PLUGINS_BASE_INSTALL_STAGING = YES
@@ -130,6 +130,13 @@ else
 GST_PLUGINS_BASE_CONF_OPT += --disable-ogg
 endif
 
+ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_PANGO),y)
+GST_PLUGINS_BASE_CONF_OPT += --enable-pango
+GST_PLUGINS_BASE_DEPENDENCIES += pango
+else
+GST_PLUGINS_BASE_CONF_OPT += --disable-pango
+endif
+
 ifeq ($(BR2_PACKAGE_GST_PLUGINS_BASE_PLUGIN_THEORA),y)
 GST_PLUGINS_BASE_CONF_OPT += --enable-theora
 GST_PLUGINS_BASE_DEPENDENCIES += libtheora