perl-path-tiny: new package
authorFrancois Perrad <fperrad@gmail.com>
Tue, 22 Jul 2014 18:17:55 +0000 (20:17 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 23 Jul 2014 19:47:08 +0000 (21:47 +0200)
Signed-off-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/perl-path-tiny/Config.in [new file with mode: 0644]
package/perl-path-tiny/perl-path-tiny.mk [new file with mode: 0644]

index b89a98ee960309239417ed7f069448d02d4c9569..40d8ba931a79f1bdc36318f9f2167edd76229c45 100644 (file)
@@ -439,6 +439,7 @@ menu "Perl libraries/modules"
        source "package/perl-json-tiny/Config.in"
        source "package/perl-mojolicious/Config.in"
        source "package/perl-net-ssleay/Config.in"
+       source "package/perl-path-tiny/Config.in"
        source "package/perl-xml-libxml/Config.in"
        source "package/perl-xml-namespacesupport/Config.in"
        source "package/perl-xml-sax-base/Config.in"
diff --git a/package/perl-path-tiny/Config.in b/package/perl-path-tiny/Config.in
new file mode 100644 (file)
index 0000000..f85e792
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PERL_PATH_TINY
+       bool "perl-path-tiny"
+       help
+         File path utility
+
+         https://github.com/dagolden/Path-Tiny
diff --git a/package/perl-path-tiny/perl-path-tiny.mk b/package/perl-path-tiny/perl-path-tiny.mk
new file mode 100644 (file)
index 0000000..9c20e74
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# perl-path-tiny
+#
+################################################################################
+
+PERL_PATH_TINY_VERSION = 0.055
+PERL_PATH_TINY_SOURCE = Path-Tiny-$(PERL_PATH_TINY_VERSION).tar.gz
+PERL_PATH_TINY_SITE = $(BR2_CPAN_MIRROR)/authors/id/D/DA/DAGOLDEN/
+PERL_PATH_TINY_DEPENDENCIES = perl
+PERL_PATH_TINY_LICENSE = Apache-2.0
+PERL_PATH_TINY_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))