bind: don't lookup zlib.h in host headers
authorBaruch Siach <baruch@tkos.co.il>
Wed, 19 Oct 2016 08:24:12 +0000 (11:24 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 19 Oct 2016 09:23:00 +0000 (11:23 +0200)
configure.in looks in host headers for zlib.h, unless given a headers
directory as --with-zlib parameter.

Note: a bug in the zlib.h header lookup logic causes configure.in to add
-l$(STAGING_DIR)/usr/include/include, and -L$(STAGING_DIR)/usr/include/lib.
But this does not affect us.

Fixes:
http://autobuild.buildroot.net/results/e96/e96a36c4da3c3be4b79a27af75a70bb8955c31a9/
http://autobuild.buildroot.net/results/e0b/e0bd7df5c19c7c65ce0009b7c2b4d4104a5c3109/
http://autobuild.buildroot.net/results/e99/e993940067f7ae841132765f91bfee7248ab125f/

Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/bind/bind.mk

index cda9fed875f9e50b82c368b3cc20d6a21c6c530d..9b5d8c56de6d87990a8390502769c1d2c5d9ae96 100644 (file)
@@ -33,7 +33,7 @@ BIND_CONF_OPTS = \
        --enable-filter-aaaa
 
 ifeq ($(BR2_PACKAGE_ZLIB),y)
-BIND_CONF_OPTS += --with-zlib
+BIND_CONF_OPTS += --with-zlib=$(STAGING_DIR)/usr/include
 BIND_DEPENDENCIES += zlib
 else
 BIND_CONF_OPTS += --without-zlib