core: include arch-specific definitions
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 14 Mar 2017 18:30:30 +0000 (11:30 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 26 Mar 2017 13:48:58 +0000 (15:48 +0200)
Allow architectures to define variables and helper macros.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Peter Korsgaard <jacmet@uclibc.org>
Signed-off-by: Max Filippov <jcmvbkbc@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Makefile

index fb2c235293652fefd2ce6cb3349362a54153118f..cceae92a261f55c3dd903ba4a8ef798e46d37900 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -479,6 +479,9 @@ all: world
 include Makefile.legacy
 
 include package/Makefile.in
+# arch/arch.mk.* must be after package/Makefile.in because it may need to
+# complement variables defined therein, like BR_NO_CHECK_HASH_FOR.
+-include $(wildcard arch/arch.mk.*)
 include support/dependencies/dependencies.mk
 
 include toolchain/*.mk