package/python-bunch: new package
authorMatt Weber <matthew.weber@rockwellcollins.com>
Tue, 12 Nov 2019 21:03:00 +0000 (15:03 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 19 Nov 2019 16:33:23 +0000 (17:33 +0100)
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
[Thomas: add missing entry to DEVELOPERS file]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/python-bunch/Config.in [new file with mode: 0644]
package/python-bunch/python-bunch.hash [new file with mode: 0644]
package/python-bunch/python-bunch.mk [new file with mode: 0644]

index b1a20eaebeaa52c5a591e5fe863bcf872d216ded..19ea83df3b6802c4a834771863c9ff16f63615bf 100644 (file)
@@ -1591,6 +1591,7 @@ F:        package/policycoreutils/
 F:     package/proftpd/
 F:     package/protobuf-c/
 F:     package/protobuf/
+F:     package/python-bunch/
 F:     package/python-colorama/
 F:     package/python-flask-cors/
 F:     package/python-iptables/
diff --git a/package/python-bunch/Config.in b/package/python-bunch/Config.in
new file mode 100644 (file)
index 0000000..89eae74
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_PYTHON_BUNCH
+       bool "python-bunch"
+       help
+         A dot-accessible dictionary (a la JavaScript objects).
+
+         http://github.com/dsc/bunch
diff --git a/package/python-bunch/python-bunch.hash b/package/python-bunch/python-bunch.hash
new file mode 100644 (file)
index 0000000..5cf2cec
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/bunch/json
+md5    0a829d64e95ed96defbcae2bf9061bb0  bunch-1.0.1.tar.gz
+sha256 50c77a0fc0cb372dfe48b5e11937d5f70e743adbf42683f3a6d2857645a76aaa  bunch-1.0.1.tar.gz
+# Locally computed sha256 checksums
+sha256 57ca95c92059c8380625192462979bd32994aae3fcdf902ff6eb1e467eeb0469  LICENSE.txt
diff --git a/package/python-bunch/python-bunch.mk b/package/python-bunch/python-bunch.mk
new file mode 100644 (file)
index 0000000..18fdc22
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-bunch
+#
+################################################################################
+
+PYTHON_BUNCH_VERSION = 1.0.1
+PYTHON_BUNCH_SOURCE = bunch-$(PYTHON_BUNCH_VERSION).tar.gz
+PYTHON_BUNCH_SITE = https://files.pythonhosted.org/packages/ef/bf/a4cf1779a4ffb4f610903fa08e15d1f4a8a2f4e3353a02afbe097c5bf4a8
+PYTHON_BUNCH_SETUP_TYPE = setuptools
+PYTHON_BUNCH_LICENSE = MIT
+PYTHON_BUNCH_LICENSE_FILES = LICENSE.txt
+
+$(eval $(python-package))