package/freeswitch: Use mod_g729 only when freeswitch-mod-bcg729 is disabled
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 6 Oct 2017 20:28:29 +0000 (22:28 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Oct 2017 21:15:38 +0000 (23:15 +0200)
mod_g729 contained in freeswitch source provides pass-through:
https://freeswitch.org/confluence/display/FREESWITCH/mod_g729

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/freeswitch/freeswitch.mk

index ce22ffc28f1f161177fe82bc3751aa3bf598d83e..defa00f47af5024109aa0f2381d223c9cccac4a4 100644 (file)
@@ -116,7 +116,6 @@ FREESWITCH_ENABLED_MODULES += \
        applications/mod_valet_parking \
        applications/mod_voicemail \
        codecs/mod_g723_1 \
-       codecs/mod_g729 \
        dialplans/mod_dialplan_asterisk \
        dialplans/mod_dialplan_xml \
        endpoints/mod_loopback \
@@ -175,6 +174,12 @@ FREESWITCH_DEPENDENCIES += alsa-lib
 FREESWITCH_ENABLED_MODULES += endpoints/mod_alsa
 endif
 
+# Use the pass-through g729 module provided by freeswitch instead of
+# the external mod_bcg729 provided by freeswitch-mod-bcg729.
+ifeq ($(BR2_PACKAGE_FREESWITCH_MOD_BCG729),)
+FREESWITCH_ENABLED_MODULES += codecs/mod_g729
+endif
+
 ifeq ($(BR2_PACKAGE_FREETYPE),y)
 FREESWITCH_DEPENDENCIES += freetype
 endif