package/patchelf: new host package
authorYann E. MORIN <yann.morin.1998@free.fr>
Wed, 30 Jul 2014 22:57:16 +0000 (00:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 31 Jul 2014 21:53:23 +0000 (23:53 +0200)
In some situations, users may want to tweak the dynamic section of the
binaries (for example to add/set the RPATH to $ORIGIN/../lib).

Because it is not trivial to do it properly from the Buildroot
infrastructure, allow those users to use patchelf (e.g. from a
post-build script) to tweak binaries.

patchelf is able to:
  - modify an existing DT_RUNPATH tags
  - add a DT_RUNPATH tag if not already present
  - do the above to the DT_RPATH tag, too
  - set the path to the interpreter
  - remove DT_NEEDED tags
  - query a binary for the DT_RUNPATH/DT_RPATH tag, or for the
    interpreter path

Does not really fix #7172, but this is an appropriate workaround.

[Thomas: change license to GPLv3+, as mentionned in the project's
README file.]

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Mike Zick <minimod@morethan.org>
Reviewed-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in.host
package/patchelf/Config.in.host [new file with mode: 0644]
package/patchelf/patchelf.mk [new file with mode: 0644]

index 062c6c918b06f721d10035fe1a69dfd7a6cb9591..e05bbfadf35dc30ea0bb9d9575875e8cb81a6219 100644 (file)
@@ -13,6 +13,7 @@ menu "Host utilities"
        source "package/omap-u-boot-utils/Config.in.host"
        source "package/openocd/Config.in.host"
        source "package/parted/Config.in.host"
+       source "package/patchelf/Config.in.host"
        source "package/pwgen/Config.in.host"
        source "package/sam-ba/Config.in.host"
        source "package/squashfs/Config.in.host"
diff --git a/package/patchelf/Config.in.host b/package/patchelf/Config.in.host
new file mode 100644 (file)
index 0000000..d1c8375
--- /dev/null
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_HOST_PATCHELF
+       bool "host patchelf"
+       help
+         PatchELF is a small utility to modify the dynamic linker
+         and RPATH of ELF executables.
+
+         http://nixos.org/patchelf.html
diff --git a/package/patchelf/patchelf.mk b/package/patchelf/patchelf.mk
new file mode 100644 (file)
index 0000000..b6b9e05
--- /dev/null
@@ -0,0 +1,12 @@
+################################################################################
+#
+# patchelf
+#
+################################################################################
+
+PATCHELF_VERSION = 0.8
+PATCHELF_SITE = http://releases.nixos.org/patchelf/patchelf-0.8/
+PATCHELF_LICENSE = GPLv3+
+PATCHELF_LICENSE_FILES = COPYING
+
+$(eval $(host-autotools-package))