busybox: don't force FEATURE_NFS_MOUNT
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 3 Nov 2012 17:47:47 +0000 (18:47 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Nov 2012 00:11:02 +0000 (01:11 +0100)
Instead of making the Busybox configuration more complicated by trying
to adjust it depending on whether RPC is available or not (which gets
complicated when RPC support can be provided by libtirpc), simplify
things by letting the user enable FEATURE_NFS_MOUNT or not depending
on whether RPC support is available or not.

Our default configuration do not enable FEATURE_NFS_MOUNT, so users
will not face any build problems by default. Only if they explicitly
enable FEATURE_NFS_MOUNT will they have to make sure that the
toolchain has RPC support, or that libtirpc is enabled (support for
this added in a followup patch).

[Peter: remove from CONFIGURE_CMDS as well]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/busybox/busybox.mk

index 33f863364887d6b71096ec5eddf79b7ba1b78299..2fa1aa53b34f7f2b1ba606a9e289cd671e9d2511 100644 (file)
@@ -81,17 +81,6 @@ define BUSYBOX_SET_IPV6
 endef
 endif
 
-# If RPC is enabled then enable nfs mounts
-ifeq ($(BR2_INET_RPC),y)
-define BUSYBOX_SET_RPC
-       $(call KCONFIG_ENABLE_OPT,CONFIG_FEATURE_MOUNT_NFS,$(BUSYBOX_BUILD_CONFIG))
-endef
-else
-define BUSYBOX_SET_RPC
-       $(call KCONFIG_DISABLE_OPT,CONFIG_FEATURE_MOUNT_NFS,$(BUSYBOX_BUILD_CONFIG))
-endef
-endif
-
 # If we're using static libs do the same for busybox
 ifeq ($(BR2_PREFER_STATIC_LIB),y)
 define BUSYBOX_PREFER_STATIC
@@ -170,7 +159,6 @@ BUSYBOX_POST_EXTRACT_HOOKS += BUSYBOX_COPY_CONFIG
 define BUSYBOX_CONFIGURE_CMDS
        $(BUSYBOX_SET_LARGEFILE)
        $(BUSYBOX_SET_IPV6)
-       $(BUSYBOX_SET_RPC)
        $(BUSYBOX_PREFER_STATIC)
        $(BUSYBOX_SET_MDEV)
        $(BUSYBOX_NETKITBASE)