ndisc6: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 21:01:00 +0000 (23:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:45 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/ndisc6/Config.in
package/ndisc6/ndisc6.mk

index 321bfbc96372bbdc411da85781e6d3ca5896e7a1..a397ea6410cb54a6889024bd7cb335b72f7f90a9 100644 (file)
@@ -1,7 +1,6 @@
 config BR2_PACKAGE_NDISC6
        bool "ndisc6 tools"
        depends on BR2_USE_MMU # fork()
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          NDisc6 is a small collection of useful tools for IPv6 networking
 
index 8326fc707b2ef6760b32bc52851b4fb0186d7d52..3ab8306d2e4b590662e86a6e2f16dd02c4b2734a 100644 (file)
@@ -7,15 +7,11 @@
 NDISC6_VERSION = 1.0.2
 NDISC6_SOURCE = ndisc6-$(NDISC6_VERSION).tar.bz2
 NDISC6_SITE = http://www.remlab.net/files/ndisc6
-NDISC6_CONF_ENV = CC="$(TARGET_CC) -std=gnu99"
+NDISC6_CONF_ENV = CC="$(TARGET_CC) -std=gnu99" LIBS=$(TARGET_NLS_LIBS)
 NDISC6_CONF_OPTS = --disable-rpath --disable-suid-install
 NDISC6_LICENSE = GPL-2.0 or GPL-3.0
 NDISC6_LICENSE_FILES = COPYING
-
-ifeq ($(BR2_NEEDS_GETTEXT_IF_LOCALE),y)
-NDISC6_DEPENDENCIES += gettext
-NDISC6_CONF_ENV += LIBS="-lintl"
-endif
+NDISC8_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 
 NDISC6_BIN_ += dnssort # perl script
 NDISC6_BIN_$(BR2_PACKAGE_NDISC6_NAME2ADDR) += name2addr addr2name