package/systemd: only create 'systemd-journal' group
authorGabe Evans <gabe@hashrabbit.co>
Fri, 1 Jul 2016 21:51:17 +0000 (23:51 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 2 Jul 2016 11:04:17 +0000 (13:04 +0200)
systemd-journal is a group used for controlling user access to the
journal when used with tools like journalctl.

While we're at it, sort the users list to improve readability.

Signed-off-by: Gabe Evans <gabe@hashrabbit.co>
Signed-off-by: Maxime Hadjinlian <maxime.hadjinlian@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/systemd/systemd.mk

index 96c34a4c99ccea71a391c5b7cc6643dbb4ed7cbc..e463c8e1fcfd16d0ef63eebfbffa9080a633995c 100644 (file)
@@ -307,16 +307,16 @@ SYSTEMD_POST_INSTALL_TARGET_HOOKS += \
        SYSTEMD_INSTALL_RESOLVCONF_HOOK
 
 define SYSTEMD_USERS
+       - - input -1 * - - - Input device group
+       - - systemd-journal -1 * - - - Journal
+       systemd-bus-proxy -1 systemd-bus-proxy -1 * - - - Proxy D-Bus messages to/from a bus
        systemd-coredump -1 systemd-coredump -1 * /var/lib/systemd/coredump - - Core Dumper
-       systemd-journal -1 systemd-journal -1 * /var/log/journal - - Journal
        systemd-journal-gateway -1 systemd-journal-gateway -1 * /var/log/journal - - Journal Gateway
        systemd-journal-remote -1 systemd-journal-remote -1 * /var/log/journal/remote - - Journal Remote
        systemd-journal-upload -1 systemd-journal-upload -1 * - - - Journal Upload
+       systemd-network -1 systemd-network -1 * - - - Network Manager
        systemd-resolve -1 systemd-resolve -1 * - - - Network Name Resolution Manager
-       systemd-bus-proxy -1 systemd-bus-proxy -1 * - - - Proxy D-Bus messages to/from a bus
        systemd-timesync -1 systemd-timesync -1 * - - - Network Time Synchronization
-       systemd-network -1 systemd-network -1 * - - - Network Manager
-       - - input -1 * - - - Input device group
 endef
 
 define SYSTEMD_DISABLE_SERVICE_TTY1