perl-class-load: new package
authorChristopher McCrory <chrismcc@gmail.com>
Mon, 20 Aug 2018 11:55:10 +0000 (04:55 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 12 Sep 2018 21:05:17 +0000 (23:05 +0200)
Signed-off-by: Christopher McCrory <chrismcc@gmail.com>
Acked-by: Francois Perrad <francois.perrad@gadz.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/perl-class-load/Config.in [new file with mode: 0644]
package/perl-class-load/perl-class-load.hash [new file with mode: 0644]
package/perl-class-load/perl-class-load.mk [new file with mode: 0644]

index 1441fbd7b32addb6ed42f04543a6e1afb6e2340c..54ede10792799a4b3a92049e0dc2215c2af60e36 100644 (file)
@@ -487,6 +487,7 @@ F:  package/targetcli-fb/
 N:     Christopher McCrory <chrismcc@gmail.com>
 F:     package/perl-appconfig/
 F:     package/perl-astro-suntime/
+F:     package/perl-class-load/
 F:     package/perl-class-std/
 F:     package/perl-class-std-fast/
 F:     package/perl-data-dump/
index 583e86a94ca6d6f4f1bc8a8322de24e121968e9d..d28e844e17ed4633459ef637ae21eb7b15a66b81 100644 (file)
@@ -667,6 +667,7 @@ if BR2_PACKAGE_PERL
 menu "Perl libraries/modules"
        source "package/perl-appconfig/Config.in"
        source "package/perl-astro-suntime/Config.in"
+       source "package/perl-class-load/Config.in"
        source "package/perl-class-std/Config.in"
        source "package/perl-class-std-fast/Config.in"
        source "package/perl-convert-asn1/Config.in"
diff --git a/package/perl-class-load/Config.in b/package/perl-class-load/Config.in
new file mode 100644 (file)
index 0000000..fef9431
--- /dev/null
@@ -0,0 +1,15 @@
+config BR2_PACKAGE_PERL_CLASS_LOAD
+       bool "perl-class-load"
+       depends on !BR2_STATIC_LIBS
+       select BR2_PACKAGE_PERL_DATA_OPTLIST
+       select BR2_PACKAGE_PERL_MODULE_IMPLEMENTATION
+       select BR2_PACKAGE_PERL_MODULE_RUNTIME
+       select BR2_PACKAGE_PERL_PACKAGE_STASH
+       select BR2_PACKAGE_PERL_TRY_TINY
+       help
+         A working (require "Class::Name") and more
+
+         https://github.com/moose/Class-Load
+
+comment "perl-class-load needs a toolchain w/ dynamic library"
+       depends on BR2_STATIC_LIBS
diff --git a/package/perl-class-load/perl-class-load.hash b/package/perl-class-load/perl-class-load.hash
new file mode 100644 (file)
index 0000000..c2900d6
--- /dev/null
@@ -0,0 +1,6 @@
+# retrieved by scancpan from http://cpan.metacpan.org/
+md5    e4c831c08df592ce8dfee0c7cfc12fd7 Class-Load-0.25.tar.gz
+sha256 2a48fa779b5297e56156380e8b32637c6c58decb4f4a7f3c7350523e11275f8f Class-Load-0.25.tar.gz
+
+# computed by scancpan
+sha256 dc030e63f20035291b90d09c2c40f296224e85878caf829ea981fc2f10910f9d LICENSE
diff --git a/package/perl-class-load/perl-class-load.mk b/package/perl-class-load/perl-class-load.mk
new file mode 100644 (file)
index 0000000..e581ba9
--- /dev/null
@@ -0,0 +1,19 @@
+################################################################################
+#
+# perl-class-load
+#
+################################################################################
+
+PERL_CLASS_LOAD_VERSION = 0.25
+PERL_CLASS_LOAD_SOURCE = Class-Load-$(PERL_CLASS_LOAD_VERSION).tar.gz
+PERL_CLASS_LOAD_SITE = $(BR2_CPAN_MIRROR)/authors/id/E/ET/ETHER
+PERL_CLASS_LOAD_DEPENDENCIES = \
+       perl-data-optlist \
+       perl-module-implementation \
+       perl-module-runtime \
+       perl-package-stash \
+       perl-try-tiny
+PERL_CLASS_LOAD_LICENSE = Artistic or GPL-1.0+
+PERL_CLASS_LOAD_LICENSE_FILES = LICENSE
+
+$(eval $(perl-package))