python-inflection: new package
authorJohn Faith <jfaith@impinj.com>
Mon, 24 Jun 2019 15:45:41 +0000 (15:45 +0000)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sun, 30 Jun 2019 13:30:52 +0000 (15:30 +0200)
A string transformation library that singularizes and pluralizes English
words, and transforms strings from CamelCase to underscored string.
Inflection is a port of Ruby on Rails' inflector to Python.

https://github.com/jpvanhal/inflection

Signed-off-by: John Faith <jfaith@impinj.com>
[Arnout: select unicodedata, add hash for license file]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
DEVELOPERS
package/Config.in
package/python-inflection/Config.in [new file with mode: 0644]
package/python-inflection/python-inflection.hash [new file with mode: 0644]
package/python-inflection/python-inflection.mk [new file with mode: 0644]

index ce3fcb2de8c131d7347fcb3fb9610ccc97070ebb..e9c521f4008a4bff98ee57ee0c08e6c63b61ce57 100644 (file)
@@ -1174,6 +1174,9 @@ F:        package/nginx-dav-ext/
 N:     John Stile <johns@msli.com>
 F:     package/dhcpcd/
 
+N:     John Faith <jfaith@impinj.com>
+F:     package/python-inflection/
+
 N:     Jonathan Ben Avraham <yba@tkos.co.il>
 F:     arch/Config.in.xtensa
 F:     package/autofs/
index bc529e0b56788decd4b6c299786d360586d1722e..d501b5a65b02ff9d3a0b2fa112a1ef0bf182726f 100644 (file)
@@ -909,6 +909,7 @@ menu "External python modules"
        source "package/python-id3/Config.in"
        source "package/python-idna/Config.in"
        source "package/python-incremental/Config.in"
+       source "package/python-inflection/Config.in"
        source "package/python-influxdb/Config.in"
        source "package/python-iniparse/Config.in"
        source "package/python-iowait/Config.in"
diff --git a/package/python-inflection/Config.in b/package/python-inflection/Config.in
new file mode 100644 (file)
index 0000000..427275b
--- /dev/null
@@ -0,0 +1,12 @@
+config BR2_PACKAGE_PYTHON_INFLECTION
+       bool "python-inflection"
+       select BR2_PACKAGE_PYTHON_UNICODEDATA if BR2_PACKAGE_PYTHON
+       select BR2_PACKAGE_PYTHON3_UNICODEDATA if BR2_PACKAGE_PYTHON3
+       help
+         A string transformation library that singularizes and
+         pluralizes English words, and transforms strings from
+         CamelCase to underscored string.
+
+         Inflection is a port of Ruby on Rails' inflector to Python
+
+         https://github.com/jpvanhal/inflection
diff --git a/package/python-inflection/python-inflection.hash b/package/python-inflection/python-inflection.hash
new file mode 100644 (file)
index 0000000..bdad35a
--- /dev/null
@@ -0,0 +1,5 @@
+# Hashes from https://pypi.python.org/pypi/inflection/json
+md5     7941165e9f148e0520023941c0886b40  inflection-0.3.1.tar.gz
+sha256  18ea7fb7a7d152853386523def08736aa8c32636b047ade55f7578c4edeb16ca  inflection-0.3.1.tar.gz
+# License file, locally calculated
+sha256  4a3f52ac1012a90db398e4c55f1d1bea501dddafef8a4b3adb7533b1d820e148  LICENSE
diff --git a/package/python-inflection/python-inflection.mk b/package/python-inflection/python-inflection.mk
new file mode 100644 (file)
index 0000000..7309880
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-inflection
+#
+################################################################################
+
+PYTHON_INFLECTION_VERSION = 0.3.1
+PYTHON_INFLECTION_SOURCE = inflection-$(PYTHON_INFLECTION_VERSION).tar.gz
+PYTHON_INFLECTION_SITE = https://pypi.python.org/packages/d5/35/a6eb45b4e2356fe688b21570864d4aa0d0a880ce387defe9c589112077f8
+PYTHON_INFLECTION_SETUP_TYPE = setuptools
+PYTHON_INFLECTION_LICENSE = MIT
+PYTHON_INFLECTION_LICENSE_FILES = LICENSE
+
+$(eval $(python-package))
+$(eval $(host-python-package))